Bug 1087507 - gtk3-branding-openSUSE discards admin/systemwide changes to /etc/gtk-3.0/settings.ini
gtk3-branding-openSUSE discards admin/systemwide changes to /etc/gtk-3.0/sett...
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Dominique Leuenberger
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-03-29 16:53 UTC by Felix Miata
Modified: 2018-05-15 12:38 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Felix Miata 2018-03-29 16:53:38 UTC
Head of /etc/gtk-3.0/settings.ini:
# 
# settings.ini file allows you to define system wide defaults for
# all GTK+ applications. This file is branding specific.
#

To reproduce:
A1-add 'gtk-primary-button-warps-slider' = false to /etc/gtk-3.0/settings.ini
A2-cause update to gtk3-branding-openSUSE 
B3-restore 'gtk-primary-button-warps-slider' to settings.ini
B4-make settings.ini immutable
B5-cause update to gtk3-branding-openSUSE 

Actual behavior:
A-update discards 'gtk-primary-button-warps-slider = false' from settings.ini
B-updating process halts because of inability to discard 'gtk-primary-button-warps-slider = false' from settings.ini
C-"you" in settings.ini comment apparently means gtk+ packager

Expected behavior:
A-'gtk-primary-button-warps-slider = false' in settings.ini is preserved
B-settings.ini.rpmnew created
C-"you" in settings.ini comment means sysadmin
Comment 1 Dominique Leuenberger 2018-04-19 15:08:02 UTC
/etc/gtk-3.0/settings.ini is marked as a config file; whenever it's replaced by the updater, a .rpmsave file is stored next to it.

As the config file is generally rather static and we are not changing a lot in there, I'll change the flags for that file to %config(noreplace) - which will change to the 'on-disk' variant to win and the rpm to put a .rpmnew file next to it.
Comment 2 Swamp Workflow Management 2018-04-26 12:30:16 UTC
This is an autogenerated message for OBS integration:
This bug (1087507) was mentioned in
https://build.opensuse.org/request/show/601532 Factory / gtk3
Comment 4 Dominique Leuenberger 2018-05-15 12:38:34 UTC
(In reply to Swamp Workflow Management from comment #2)
> This is an autogenerated message for OBS integration:
> This bug (1087507) was mentioned in
> https://build.opensuse.org/request/show/601532 Factory / gtk3

Fix has been merged