Bug 1087449 - Transactional Server Role in Leap 15/TW - Allows installation on disks under 16GB
Transactional Server Role in Leap 15/TW - Allows installation on disks under ...
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kubic
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Richard Brown
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-03-29 12:24 UTC by Richard Brown
Modified: 2018-04-03 18:28 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Brown 2018-03-29 12:24:07 UTC
It shouldn't, it should behave like Kubic.

I'm on it :)
Comment 2 Ludwig Nussel 2018-04-03 15:53:47 UTC
Looks like this makes snapshots no longer configurable. I thought on low disk space snapshots get disabled. Is that still the case?
Comment 3 Richard Brown 2018-04-03 18:28:11 UTC
(In reply to Ludwig Nussel from comment #2)
> Looks like this makes snapshots no longer configurable. I thought on low
> disk space snapshots get disabled. Is that still the case?

When low disk space, snapshots get disabled by default, yes

But on a Transactional Host with RO fs that can be a rather painful prospect - a read-only rootfs without snapshots means you have a read-only rootfs with no way of patching it

Therefore the intended behaviour for the control.xml in this system_role is to require snapshots and not allow configuration of that

Note this flag should only apply for the transactional system role - that is how I implemented it in the control.xml and how it's documented.

That said, that flag is also currently broken (P1, YaST team on it - https://bugzilla.suse.com/show_bug.cgi?id=1087486 )

So right now, the 'do not configure snapshots for this system role' is a noop.

I'm reasonably sure users will be okay most of the time, as I've been strict with the (working) min_disk requirements, perfectly matching Kubic where they work out well enough I was never able to notice the "disable snapshots" flag was non-functional.

So right now, with those changes, I'm expecting YaST to report that a partition solution is not possible if their disk is too small, just like we have on Kubic.

However med/long term (or whenever YaST fix that bug) my desire would be to relax the space requirements for ServerRO Leap/TW compared to Kubic. I would prefer they are more flexible like we're used to for Leap/TW, but still rely on the "at least require snapshots" rule to give the assurance that the role will always work.