Bug 1087331 - [cloud-init] 'apply_network_config is not currently implemented' message
[cloud-init] 'apply_network_config is not currently implemented' message
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kubic
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Robert Schweikert
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-03-28 15:49 UTC by Mikhail Kasimov
Modified: 2019-08-01 13:16 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
apply_network_config is not currently implemented (7.98 KB, image/png)
2018-03-28 15:49 UTC, Mikhail Kasimov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mikhail Kasimov 2018-03-28 15:49:22 UTC
Created attachment 765288 [details]
apply_network_config is not currently implemented

Hello!

've got a warning message on Kubic booting (on VirtualBox VM):
========================
cloud-init: __init__.py[WARNING]:apply_network_config is not currently implemented for distribution '<class 'cloudinit.distros.sles.Distro'>'. Attempting to use apply_network
========================

see screenshot in attach. Known issue?
Comment 1 Mikhail Kasimov 2018-04-04 17:50:14 UTC
UPD: CaaSP doesn't have such alert.
Comment 2 Thorsten Kukuk 2018-04-05 13:37:07 UTC
(In reply to Mikhail Kasimov from comment #1)
> UPD: CaaSP doesn't have such alert.

Since CaaSP has the same cloud-init version, it has of course the same message.
Comment 3 Mikhail Kasimov 2018-04-05 13:52:16 UTC
(In reply to Thorsten Kukuk from comment #2)
> (In reply to Mikhail Kasimov from comment #1)
> > UPD: CaaSP doesn't have such alert.
> 
> Since CaaSP has the same cloud-init version, it has of course the same
> message.

Yesterday, when I installed CaaSP on VM for testing, there were no such message. And Kubic has it.

Will try to do video-snippet for reproduction.
Comment 4 Robert Schweikert 2018-04-05 20:39:06 UTC
This is a warning message, cloud-init falls back to another implementation to set up networking.

This will not change any time soon.
Comment 5 Robert Schweikert 2018-10-25 21:51:38 UTC
created request id 644740
Comment 6 Swamp Workflow Management 2018-10-25 22:10:06 UTC
This is an autogenerated message for OBS integration:
This bug (1087331) was mentioned in
https://build.opensuse.org/request/show/644740 Factory / cloud-init
Comment 10 Swamp Workflow Management 2018-12-28 20:15:52 UTC
SUSE-RU-2018:4288-1: An update that has 7 recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1087331,1095627,1097388,1099340,1101894,1111427,1114160
CVE References: 
Sources used:
SUSE Linux Enterprise Module for Public Cloud 15 (src):    cloud-init-18.4-5.3.3
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 (src):    cloud-init-18.4-5.3.3
Comment 11 Swamp Workflow Management 2018-12-29 14:10:06 UTC
openSUSE-RU-2018:4303-1: An update that has 7 recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1087331,1095627,1097388,1099340,1101894,1111427,1114160
CVE References: 
Sources used:
openSUSE Leap 15.0 (src):    cloud-init-18.4-lp150.2.9.1
Comment 20 Swamp Workflow Management 2019-06-27 13:13:36 UTC
SUSE-RU-2019:1715-1: An update that has 15 recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1087331,1095627,1097388,1099340,1101894,1111427,1114160,1116767,1119397,1121878,1123694,1125950,1125992,1126101,1132692
CVE References: 
Sources used:
SUSE Linux Enterprise Software Development Kit 12-SP4 (src):    dhcp-4.3.3-10.16.4
SUSE Linux Enterprise Software Development Kit 12-SP3 (src):    dhcp-4.3.3-10.16.4
SUSE Linux Enterprise Server 12-SP4 (src):    dhcp-4.3.3-10.16.4
SUSE Linux Enterprise Server 12-SP3 (src):    dhcp-4.3.3-10.16.4
SUSE Linux Enterprise Module for Public Cloud 12 (src):    cloud-init-18.5-37.21.1
SUSE Linux Enterprise Desktop 12-SP4 (src):    dhcp-4.3.3-10.16.4
SUSE Linux Enterprise Desktop 12-SP3 (src):    dhcp-4.3.3-10.16.4
SUSE CaaS Platform 3.0 (src):    cloud-init-18.5-37.21.1, dhcp-4.3.3-10.16.4
OpenStack Cloud Magnum Orchestration 7 (src):    cloud-init-18.5-37.21.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 21 Swamp Workflow Management 2019-07-01 10:13:18 UTC
openSUSE-RU-2019:1681-1: An update that has 15 recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1087331,1095627,1097388,1099340,1101894,1111427,1114160,1116767,1119397,1121878,1123694,1125950,1125992,1126101,1132692
CVE References: 
Sources used:
openSUSE Leap 42.3 (src):    cloud-init-18.5-40.1, dhcp-4.3.3-11.9.1