Bug 1087316 - [automake1.16] libtool fails to build
[automake1.16] libtool fails to build
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Basesystem
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Philipp Thomas
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-03-28 14:13 UTC by Dominique Leuenberger
Modified: 2018-05-08 14:35 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dominique Leuenberger 2018-03-28 14:13:46 UTC
Automake has been submitted for integration into Tumbleweed

libtool is amongst the packages failing to build:

[   48s] + rm -f doc/libtool.info
[   48s] + make V=1 -j6
[   48s] CDPATH="${ZSH_VERSION+.}:" && cd . && /bin/sh /home/abuild/rpmbuild/BUILD/libtool-2.4.6/build-aux/missing aclocal-1.15 -I m4
[   48s] /home/abuild/rpmbuild/BUILD/libtool-2.4.6/build-aux/missing: line 81: aclocal-1.15: command not found
[   48s] WARNING: 'aclocal-1.15' is missing on your system.
[   48s]          You should only need it if you modified 'acinclude.m4' or
[   48s]          'configure.ac' or m4 files included by 'configure.ac'.
[   48s]          The 'aclocal' program is part of the GNU Automake package:
[   48s]          <http://www.gnu.org/software/automake>
[   48s]          It also requires GNU Autoconf, GNU m4 and Perl in order to run:
[   48s]          <http://www.gnu.org/software/autoconf>
[   48s]          <http://www.gnu.org/software/m4/>
[   48s]          <http://www.perl.org/>
[   48s] make: *** [Makefile:1031: aclocal.m4] Error 127
[   48s] error: Bad exit status from /var/tmp/rpm-tmp.Vsi6jm (%build)


As it does an implicit bootstrap, the same version automake is expected as when the tarball was created
Comment 1 Dominique Leuenberger 2018-03-28 14:21:09 UTC
Can also be observed at 
https://build.opensuse.org/package/show/devel:tools:building/libtool
Comment 2 Philipp Thomas 2018-05-08 14:35:42 UTC
Libtool is fixed in TW.