Bug 1087263 - [Build 20180324] openQA test fails in php7_postgresql96
[Build 20180324] openQA test fails in php7_postgresql96
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Installation
Current
PowerPC Other
: P5 - None : Normal (vote)
: ---
Assigned To: Dominique Leuenberger
Jiri Srain
https://openqa.opensuse.org/tests/643...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-03-28 08:40 UTC by Michel Normand
Modified: 2018-03-28 12:26 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
php7_postgresql96-zypper-20180326.log (2.90 MB, text/x-log)
2018-03-28 08:40 UTC, Michel Normand
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michel Normand 2018-03-28 08:40:36 UTC
Created attachment 765216 [details]
php7_postgresql96-zypper-20180326.log

As per attached zypper log php7_postgresql96 retrieved from "oss" repo while other php7* packages retrieved from "openSUSE-20180324" repo.

Need to understand why php7_postgresql96 not retrieved from same repo.

I do not know how is built the "openSUSE-20180324" repo and if able to access remotely for investigation.


I checked in OBS TW PowerPC project, related rpm build time are the same. 
  ===
  https://build.opensuse.org/package/binary/openSUSE:Factory:PowerPC/php7/standard/ppc64/php7-7.2.3-2.1.ppc64.rpm
  Build Time: 2018-03-24 18:16:38 +0000 (4 days ago)
  https://build.opensuse.org/package/binary/openSUSE:Factory:PowerPC/php7/standard/ppc64/php7-pgsql-7.2.3-2.1.ppc64.rpm
  Build Time: 2018-03-24 18:16:42 +0000 (4 days ago)
  ===

## Observation

openQA test in scenario opensuse-Tumbleweed-DVD-ppc64-textmode@ppc64 fails in
[php7_postgresql96](https://openqa.opensuse.org/tests/643167/modules/php7_postgresql96/steps/40)


## Reproducible

Fails since (at least) Build [20180313](https://openqa.opensuse.org/tests/633487)


## Expected result

Last good: [20180311](https://openqa.opensuse.org/tests/631865) (or more recent)


## Further details

Always latest result in this scenario: [latest](https://openqa.opensuse.org/tests/latest?test=textmode&machine=ppc64&flavor=DVD&version=Tumbleweed&arch=ppc64&distri=opensuse)
Comment 1 Michel Normand 2018-03-28 10:28:11 UTC
same failure ppc64 on next snapshot 20180326
https://openqa.opensuse.org/tests/644603#step/php7_postgresql96/40
But not failure for ppc64le.


If I retrieve the ppc64 and ppc64le isos to mount and find provided php7*rpm
There is only 11 packages for ppc64, while 40 for ppc64le.
This is confirmed in OBS by the related DVD5*.group files.

Dominique are we able to update the DVD5-ppc64.group ?
===
[normand@sf1:/srv/ftp/pub/linux/opensuse/factory/ppc64/iso]
$find ../os/ -name php7\*rpm |wc -l
11
[normand@sf1:/srv/ftp/pub/linux/opensuse/factory/ppc64le/iso]
$find ../os/ -name php7\*rpm |wc -l
40
===
$osc ls -b openSUSE:Factory:PowerPC -r standard -a ppc64 |grep ^php7 |wc -l
149
$osc ls -b openSUSE:Factory:PowerPC -r standard -a ppc64le |grep ^php7 |wc -l
149
===
[michel@twppc64le2:~/work/openSUSE:Factory:PowerPC/000product]
$grep -Hni \"php7 DVD5-ppc64.group |wc -l
11
[michel@twppc64le2:~/work/openSUSE:Factory:PowerPC/000product]
$grep -Hni \"php7 DVD5-ppc64le.group |wc -l
40
===
Comment 2 Dominique Leuenberger 2018-03-28 11:39:49 UTC
(In reply to Michel Normand from comment #1)
> Dominique are we able to update the DVD5-ppc64.group ?

The .group files are calculated based on dependencies; any manual change would
a) only pamper over an underlying problem
b) be overwritten the next time the pkg list generator runs

I could identify a bug in the pkg list generator code that skipped the include of suggested package for ppc64 (regex error)

https://build.opensuse.org/package/rdiff/openSUSE:Factory:PowerPC/000product?linkrev=base&rev=32 shows that the recalculated group for ppc64 is now much more complete
Comment 3 Josef Reidinger 2018-03-28 12:24:08 UTC
Dominique who is responsible for this generator? I think it has nothing to do with YaST.
Comment 4 Dominique Leuenberger 2018-03-28 12:26:18 UTC
(In reply to Josef Reidinger from comment #3)
> Dominique who is responsible for this generator? I think it has nothing to
> do with YaST.

Indeed - that's not yast, but me. The bug is fixed already.