Bug 1086807 - postfix: error about not existing file
postfix: error about not existing file
Status: RESOLVED WORKSFORME
: 1092819 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Peter Varkoly
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-03-26 08:41 UTC by Thorsten Kukuk
Modified: 2021-09-06 08:37 UTC (History)
8 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thorsten Kukuk 2018-03-26 08:41:30 UTC
During update I got the following error message:

# 2018-03-24 01:13:53 postfix-3.3.0-1.1.x86_64.rpm installed ok
# Additional rpm output:
# SysV service postfix does not exist, skipping
# warning: /etc/postfix/master.cf created as /etc/postfix/master.cf.rpmnew
# Executing upgrade-configuration.
# chown: cannot access '/usr/lib/postfix/bin//postfix-ldap.so': No such file or directory
Comment 1 Bernhard Voelker 2018-03-27 07:52:00 UTC
Indeed, it should probably read '/usr/lib/postfix/postfix-ldap.so'.
Comment 2 Ian Powell 2018-04-23 08:57:54 UTC
I got this with Tumbleweed snapshot 20180417

Additional rpm output:
Executing upgrade-configuration.                                                                                                                                                                    
chown: cannot access '/usr/lib/postfix/bin//postfix-ldap.so': No such file or directory                                                                                                             
Updating /etc/sysconfig/postfix ...                                                                                                                                                                 
Updating /etc/sysconfig/mail ...
Comment 3 John Paul Adrian Glaubitz 2020-05-13 15:18:02 UTC
The bug is in the "postfix" command which is invoked by the postinst script:

suse-laptop:~ # /usr/sbin/postfix set-permissions
postfix: Postfix is running with backwards-compatible default settings
postfix: See http://www.postfix.org/COMPATIBILITY_README.html for details
postfix: To disable backwards compatibility use "postconf compatibility_level=2" and "postfix reload"
chown: cannot access '/usr/lib/postfix/bin//postfix-ldap.so': No such file or directory
suse-laptop:~ #

However, normally the path is set in shlib_directory as /usr/lib/postfix during build. So, the only source for the additional "bin/" in the path string can be from the postfix source itself.

I can't reproduce the bug on Debian, however:

root@kapitsa:~# postfix set-permissions
postfix: Postfix is running with backwards-compatible default settings
postfix: See http://www.postfix.org/COMPATIBILITY_README.html for details
postfix: To disable backwards compatibility use "postconf compatibility_level=2" and "postfix reload"
root@kapitsa:~#
Comment 4 Pi Ny 2020-12-28 13:23:36 UTC
Confirm this bug on 15.2 during upgrade from 15.1.

Excerpt from zypp history

```
# 2020-12-25 22:32:12 postfix-3.4.7-lp152.2.3.1.x86_64.rpm installed ok
# Additional rpm output:
# warning: /etc/postfix/main.cf created as /etc/postfix/main.cf.rpmnew
# Executing upgrade-configuration.
# chown: cannot access '/usr/lib/postfix/bin//postfix-ldap.so': No such file or directory
# Updating /etc/sysconfig/postfix ...
# Updating /etc/sysconfig/mail ...
# 
2020-12-25 22:32:12|install|postfix|3.4.7-lp152.2.3.1|x86_64||repo-15.2-update-oss|e0e36e5cf4f8aae5dac118d3fb2828b319f0a278ce352d63edc046413201ca73|
```

```
# ll /usr/lib/postfix/postfix-ldap.so
-rwxr-xr-x 1 root root 34792 Dec  9 23:54 /usr/lib/postfix/postfix-ldap.so
```
Comment 5 Peter Varkoly 2021-09-05 08:20:25 UTC
*** Bug 1092819 has been marked as a duplicate of this bug. ***
Comment 6 Peter Varkoly 2021-09-05 08:34:21 UTC
Normaly /usr/lib/postfix/postfix-ldap.so will not be checked because it is in a separate package: postfix-ldap. Thats why postfix-ldap.so is commented out in /usr/lib/postfix/postfix-files:

...
$shlib_directory/libpostfix-master.so:f:root:-:755
#$shlib_directory/postfix-ldap.so:f:root:-:755
$shlib_directory/postfix-lmdb.so:f:root:-:755
...

I'ev tested it on a lot of installations and I could not reproduce the problem.
Please check the content of /usr/lib/postfix/postfix-files and /usr/lib/postfix/postfix-files.d/. Furthermore check the value of shlib_directory. This should be:

postconf shlib_directory
shlib_directory = /usr/lib/postfix
Comment 7 Thomas Moldt 2021-09-06 08:37:00 UTC
(In reply to Peter Varkoly from comment #6)
> Normaly /usr/lib/postfix/postfix-ldap.so will not be checked because it is
> in a separate package: postfix-ldap. Thats why postfix-ldap.so is commented
> out in /usr/lib/postfix/postfix-files:
> 
> ...
> $shlib_directory/libpostfix-master.so:f:root:-:755
> #$shlib_directory/postfix-ldap.so:f:root:-:755
> $shlib_directory/postfix-lmdb.so:f:root:-:755
> ...

Interesting. This is what I get:
# cat /usr/lib/postfix/postfix-files | grep shlib
$shlib_directory/postfix-ldap.so:f:root:-:755
$shlib_directory/postfix-pcre.so:f:root:-:755

But yet, the error message did not occur any more in the last three updates of postfix, even though I didn't change anything:

# cat /var/log/zypp/history | grep postfix
...
# 2020-06-10 13:24:39 postfix-3.4.7-lp152.1.30.x86_64.rpm installed ok
# chown: cannot access '/usr/lib/postfix/bin//postfix-ldap.so': No such file or directory
# Updating /etc/sysconfig/postfix ...
2020-06-10 13:24:39|install|postfix|3.4.7-lp152.1.30|x86_64||repo-oss|923d7fbcd757ebe415b9bc5fe4167f3cf35b408bbf144c9d0be72b45f410d070|
#       /etc/permissions.d/postfix
# 2020-12-13 13:33:32 postfix-3.4.7-lp152.2.3.1.x86_64.rpm installed ok
# chown: cannot access '/usr/lib/postfix/bin//postfix-ldap.so': No such file or directory
# Updating /etc/sysconfig/postfix ...
2020-12-13 13:33:32|install|postfix|3.4.7-lp152.2.3.1|x86_64||repo-update|e0e36e5cf4f8aae5dac118d3fb2828b319f0a278ce352d63edc046413201ca73|
# 2021-02-06 19:34:03 postfix-3.4.7-lp152.2.6.1.x86_64.rpm installed ok
# Editing /etc/postfix/master.cf, adding missing entry for tlsmgr service
#      /etc/postfix/postfix-files /etc/postfix/postfix-script
#      /etc/postfix/post-install
# Updating /etc/sysconfig/postfix ...
2021-02-06 19:34:03|install|postfix|3.4.7-lp152.2.6.1|x86_64||repo-update|2d8ed0a5e27a2d0af2a8a0c7b9fb923208d352fcd7d0e4b3b050ad476850b077|
# 2021-07-03 16:07:34 postfix-3.4.7-lp152.2.9.1.x86_64.rpm installed ok
#      /etc/postfix/postfix-files /etc/postfix/postfix-script
#      /etc/postfix/post-install
# Updating /etc/sysconfig/postfix ...
2021-07-03 16:07:34|install|postfix|3.4.7-lp152.2.9.1|x86_64||repo-update|2db8e5faaba2ff10dcf2855dfe2ccf796497d0549627e54392427ffbabb00740|

Apparently the error was fixed regardless of what's set in /usr/lib/postfix/postfix-files.