Bug 1086783 - libsolv-tools uninstall attempted by zypper dup
libsolv-tools uninstall attempted by zypper dup
Status: RESOLVED DUPLICATE of bug 1087723
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: libzypp
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-03-26 06:26 UTC by Vit Pelcak
Modified: 2018-04-13 10:23 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
zypper logs (1.06 MB, application/x-xz)
2018-04-06 12:08 UTC, Vit Pelcak
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vit Pelcak 2018-03-26 06:26:27 UTC
Hello.

I noticed that the latest zypper dup is trying to uninstall libsolv-tools

rheia:~ # zypper dup
Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
Loading repository data...
Reading installed packages...
Computing distribution upgrade...

The following 2 items are locked and will not be changed by any action:
 Available:
  PackageKit gnome-packagekit

The following NEW package is going to be installed:
  PackageKit-gstreamer-plugin

The following package is going to be REMOVED:
  libsolv-tools

1 new package to install, 1 to remove.
Overall download size: 122.8 KiB. Already cached: 0 B. After the operation, 4.4 MiB will be freed.
Continue? [y/n/...? shows all options] (y): 
Retrieving package PackageKit-gstreamer-plugin-1.1.9-1.2.x86_64                                 (1/1), 122.8 KiB ( 18.6 KiB unpacked)
Retrieving: PackageKit-gstreamer-plugin-1.1.9-1.2.x86_64.rpm ..................................................................[done]
Checking for file conflicts: ..................................................................................................[done]
(1/2) Removing libsolv-tools-0.6.32-1.1.x86_64 ...............................................................................[error]
Removal of (118845)libsolv-tools-0.6.32-1.1.x86_64(@System) failed:
Error: Subprocess failed. Error: RPM failed: error: package libsolv-tools-0.6.32-1.1.x86_64 is not installed

Abort, retry, ignore? [a/r/i] (a): 
Problem occurred during or after installation or removal of packages:
Installation aborted by user
Please see the above error message for a hint.
rheia:~ # zypper in libsolv-tools
Comment 1 Michael Andres 2018-04-06 09:04:53 UTC
=== Please create and attach a solver testcase:
>    # zypper dup --debug-solver
>    ...
>    Generating solver test case...
>    Solver test case generated successfully at /var/log/zypper.solverTestCase.  
Then pack the output directory together with /var/log/zypper.log and attach it to the bugreport. 

In case the testcase exceeds the 10MB limit for bugzilla uploads, you can use 'split' to divide the file into smaller pieces: 
>  $ cd /tmp
>  $ tar cvjf zypper.solverTestCase.tar.bz2 /var/log/zypper.solverTestCase/
>  $ split -b 10M --additional-suffix=-zypper.solverTestCase.tar.bz2 \
>    zypper.solverTestCase.tar.bz2
The created pieces will be named like this:
>  xaa-zypper.solverTestCase.tar.bz2
>  xab-zypper.solverTestCase.tar.bz2
>  xac-zypper.solverTestCase.tar.bz2
>  ...
Comment 2 Michael Schröder 2018-04-06 09:40:31 UTC
What version of libsolv-tools is installed? I.e. what's the output of
rpm -qa libsolv-tools?
Comment 3 Vit Pelcak 2018-04-06 10:18:06 UTC
I was able to resolve it by manual forced upgrade of libsolv-tools.

It was probably something wrong on my side.

Not an issue anymore.
So I decided to close it.
Comment 4 Michael Andres 2018-04-06 11:06:51 UTC
@Vit: 
The problem is that we receive similar reports from different distributions.  Maybe you can add your /var/log/zypper.log (and maybe the last one rotated) so we can investigate this?
Comment 5 Vit Pelcak 2018-04-06 12:08:56 UTC
Created attachment 766277 [details]
zypper logs

OK. Here yo are.

I think that my mess up was, that instead of running zypper dup, I updated zypper first and then ran zypper dup.

Then I realized that is not supported scenario. that's why I think my bug is invalid.

Maybe the complaints are caused by that, too.
Comment 6 Michael Andres 2018-04-13 10:20:04 UTC
@Vit: Similar reports indicate it may be caused by a problem in the rpmdb. I'd recommend to run `rpm --rebuilddb` on the affected system.
Comment 7 Michael Andres 2018-04-13 10:23:35 UTC

*** This bug has been marked as a duplicate of bug 1087723 ***