Bug 1086757 - Images for Raspberry Pi 1/2/3 does not boot - only Splash Screen Rainbow
Images for Raspberry Pi 1/2/3 does not boot - only Splash Screen Rainbow
Status: VERIFIED FIXED
: 1087791 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Bootloader
Current
Other openSUSE Factory
: P5 - None : Normal (vote)
: ---
Assigned To: Alexander Graf
Jiri Srain
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-03-25 16:18 UTC by Kasimir _
Modified: 2021-10-12 18:40 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kasimir _ 2018-03-25 16:18:37 UTC
I have tried the current images [1] of the Raspberry Pi 1/2/3 and get only the Splash Screen Rainbow. No messages are output through the serial console.

[1]
RPi1: openSUSE-Tumbleweed-ARM-JeOS-raspberrypi.armv6l-2018.03.25-Build1.1.raw.xz
RPi2: openSUSE-Tumbleweed-ARM-JeOS-raspberrypi2.armv7l-2018.03.25-Build1.1.raw.xz
RPi3: openSUSE-Tumbleweed-ARM-JeOS-raspberrypi3.aarch64-2018.03.25-Build1.1.raw.xz
Comment 1 Kasimir _ 2018-03-26 15:40:10 UTC
The Raspberry Pi's probably have a problem with the current u-boot (2018.3).
After I replaced the u-boot.bin with an older version (2018.1), the boot process started.

Result:
RPi1 / 2: Booting, but still likely to have a problem with the initramfs
RPi3: Boot complete
Comment 2 Kasimir _ 2018-03-27 07:19:59 UTC
It seems to be the patch 0004-rpi-use-firmware-provided-device-tr.patch[2]. After removing these patches, the boot process continues. (tested on RPi1 and RPi3)

[2] https://build.opensuse.org/package/view_file/openSUSE:Factory:ARM/u-boot/0004-rpi-Use-firmware-provided-device-tr.patch?expand=1
Comment 3 Andreas Färber 2018-03-27 14:46:42 UTC
raspberrypi-firmware-dt package appears to be missing:

https://build.opensuse.org/package/view_file/openSUSE:Factory:ARM/JeOS/Images.kiwi.in?expand=1
Comment 4 Kasimir _ 2018-03-29 14:05:24 UTC
I have built images with the raspberrypi-firmware-dt package [3].
The RPi3 now boots to the console.
RPi1 and RPi2 are probably in a boot loop. The ACT-LED flashes briefly, the Splash Screen Rainbow appears briefly, the screen turns black and it starts from the beginning. There is no output on the serial console.

[3] https://build.opensuse.org/project/show/home:kasimir:RPi:ToTest
Comment 5 Swamp Workflow Management 2018-04-04 08:30:05 UTC
This is an autogenerated message for OBS integration:
This bug (1086757) was mentioned in
https://build.opensuse.org/request/show/593402 Factory:ARM / JeOS
Comment 6 Alexander Graf 2018-04-04 12:41:25 UTC
*** Bug 1087791 has been marked as a duplicate of this bug. ***
Comment 7 Alexander Graf 2018-04-05 13:25:29 UTC
The 32bit RPis had an issue where U-Boot would just refuse to load because the DT coming from firmware didn't mark serial output devices as "u-boot early probe".

This is fixed in the current submission of U-Boot to Factory.
Comment 8 Alexander Graf 2018-04-05 15:58:41 UTC
I just verified that the latest image plus the current U-Boot submission fix booting on the RPi2.

It might take a few days until the fixed images get published unfortunately.
Comment 10 Swamp Workflow Management 2018-04-18 14:40:26 UTC
This is an autogenerated message for OBS integration:
This bug (1086757) was mentioned in
https://build.opensuse.org/request/show/597801 Factory:ARM:Live / JeOS
Comment 11 Swamp Workflow Management 2018-05-18 12:20:06 UTC
This is an autogenerated message for OBS integration:
This bug (1086757) was mentioned in
https://build.opensuse.org/request/show/610290 15.0:Ports:Live / JeOS
Comment 12 Freek de Kruijf 2018-05-18 13:31:31 UTC
(In reply to Swamp Workflow Management from comment #11)
> This is an autogenerated message for OBS integration:
> This bug (1086757) was mentioned in
> https://build.opensuse.org/request/show/610290 15.0:Ports:Live / JeOS

I can confirm all three types of images mentioned in the original report now work.
Comment 13 Swamp Workflow Management 2018-05-18 14:10:10 UTC
This is an autogenerated message for OBS integration:
This bug (1086757) was mentioned in
https://build.opensuse.org/request/show/610356 15.0:Ports:Live / JeOS
Comment 14 Andreas Färber 2018-05-18 14:13:25 UTC
Verified as per comment #12.
Comment 15 Swamp Workflow Management 2019-04-02 16:00:35 UTC
This is an autogenerated message for OBS integration:
This bug (1086757) was mentioned in
https://build.opensuse.org/request/show/690698 15.1:ARM:Images / JeOS
Comment 16 OBSbugzilla Bot 2021-04-27 07:40:11 UTC
This is an autogenerated message for OBS integration:
This bug (1086757) was mentioned in
https://build.opensuse.org/request/show/888681 Factory:ARM / JeOS
Comment 17 OBSbugzilla Bot 2021-10-12 16:40:28 UTC
This is an autogenerated message for OBS integration:
This bug (1086757) was mentioned in
https://build.opensuse.org/request/show/924915 Factory:ARM / JeOS
Comment 18 OBSbugzilla Bot 2021-10-12 18:40:26 UTC
This is an autogenerated message for OBS integration:
This bug (1086757) was mentioned in
https://build.opensuse.org/request/show/924923 Factory:ARM / JeOS