Bug 1086166 - nothing provides libpng12-0 needed by lsb-4.0-31.2.x86_64
nothing provides libpng12-0 needed by lsb-4.0-31.2.x86_64
Status: RESOLVED WONTFIX
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Stephan Kulow
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-03-21 06:44 UTC by Jason Evans
Modified: 2019-04-04 17:40 UTC (History)
5 users (show)

See Also:
Found By: Community User
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jason Evans 2018-03-21 06:44:13 UTC
lsb is a dependency of a package that I am trying to install. It requires libpng12-2

Problem: nothing provides libpng12-0 needed by lsb-4.0-31.2.x86_64
 Solution 1: do not install atom-1.25.0-0.1.x86_64
 Solution 2: break lsb-4.0-31.2.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/c] (c): 2
Resolving dependencies...
Resolving package dependencies...

---

The version of lsb that I am trying to install is from the Tumbeweed repo:

jsevans@worklinux:~> zypper info lsb
Loading repository data...
Reading installed packages...


Information for package lsb:
----------------------------
Repository     : Main Repository (OSS)   
Name           : lsb                     
Version        : 4.0-31.2                
Arch           : x86_64                  
Vendor         : openSUSE                
Installed Size : 110 B                   
Installed      : Yes (automatically)     
Status         : up-to-date              
Source package : lsb-4.0-31.2.src        
Summary        : Linux Standard Base Core
Description    :                         
    Necessary files and dependencies for the Linux Standard Base (LSB)
    Core.

The version of libpng that currently is provided is libpng16-16

jsevans@worklinux:~> zypper info libpng16-16
Loading repository data...
Reading installed packages...


Information for package libpng16-16:
------------------------------------
Repository     : Main Repository (OSS)                                 
Name           : libpng16-16                                           
Version        : 1.6.34-2.1                                            
Arch           : x86_64                                                
Vendor         : openSUSE                                              
Installed Size : 270.0 KiB                                             
Installed      : Yes (automatically)                                   
Status         : up-to-date                                            
Source package : libpng16-1.6.34-2.1.src                               
Summary        : Library for the Portable Network Graphics Format (PNG)
Description    :                                                       
    libpng is the official reference library for the Portable Network
    Graphics format (PNG).
Comment 1 Stephan Kulow 2018-03-21 06:58:00 UTC
What package is that? most packages require lsb 'just so', not because they are really lsb compliant. So just installing the package by forcing dependencies and locking lsb is the preferred solution.
Comment 2 Thorsten Kukuk 2018-03-21 08:03:54 UTC
I bet thats from atom.io.

The RPM is totally broken. The dependencies are:
lsb-core-noarch
libXss.so.1()(64bit)
libsecret-1.so.0()(64bit)


But ldd atom shows you over 80 libraries, from which the majority is not part of LSB at all, especially not of lsb-core. libpng doesn't seem to be in that list.

So all you can do is to install with rpm --nodeps and hope, that it works.
Somebody should create a bug report for them, that they fix their packaging ...
Comment 3 Jason Evans 2018-03-21 08:49:55 UTC
(In reply to Thorsten Kukuk from comment #2)
> I bet thats from atom.io.
> 
> The RPM is totally broken. The dependencies are:
> lsb-core-noarch
> libXss.so.1()(64bit)
> libsecret-1.so.0()(64bit)
> 
> 
> But ldd atom shows you over 80 libraries, from which the majority is not
> part of LSB at all, especially not of lsb-core. libpng doesn't seem to be in
> that list.
> 
> So all you can do is to install with rpm --nodeps and hope, that it works.
> Somebody should create a bug report for them, that they fix their packaging
> ...

You're right, it is. I will spin up a new fresh tumbleweed VM and try to install the lsb package straight without atom. If it is still requiring the older libpng, then it is a requirements bug in lsb itself.
Comment 4 Thorsten Kukuk 2018-03-21 09:02:02 UTC
(In reply to Jason Evans from comment #3)

> You're right, it is. I will spin up a new fresh tumbleweed VM and try to
> install the lsb package straight without atom. If it is still requiring the
> older libpng, then it is a requirements bug in lsb itself.

It's not a bug in lsb package, the LSB spec really requires libpng12-0.
The bugs are, that LSB is outdated and no longer compatible with Tumbleweed.
Comment 5 Jason Evans 2018-03-21 09:57:39 UTC
> It's not a bug in lsb package, the LSB spec really requires libpng12-0.
> The bugs are, that LSB is outdated and no longer compatible with Tumbleweed.

I understand but it looks like there are dependency issues in Tumbleweed itself even though this is an issue from upstream.

From fresh VM:

jsevans@linux-a29s:~> sudo zypper in lsb

We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:

    #1) Respect the privacy of others.
    #2) Think before you type.
    #3) With great power comes great responsibility.

[sudo] password for root: 
Sorry, try again.
[sudo] password for root: 
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: nothing provides libpng12-0 needed by lsb-4.0-31.2.x86_64
 Solution 1: do not install lsb-4.0-31.2.x86_64
 Solution 2: break lsb-4.0-31.2.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/c] (c):
Comment 6 Dominique Leuenberger 2018-03-21 14:10:53 UTC
(In reply to Jason Evans from comment #5)
> I understand but it looks like there are dependency issues in Tumbleweed
> itself even though this is an issue from upstream.
> 
> From fresh VM:
> 
> jsevans@linux-a29s:~> sudo zypper in lsb
> 
> We trust you have received the usual lecture from the local System
> Administrator. It usually boils down to these three things:
> 
>     #1) Respect the privacy of others.
>     #2) Think before you type.
>     #3) With great power comes great responsibility.

Indeed, libpng12-0 has been purged from Tumbleweed; the lsb package (and the lsb spec) is one of two consumers of this (well outdated) library. The 2nd one being steam.

the lsb package will best just be converted to a dummy so that 3rd parties can rely on the package name, even knowing that the system is not 'lsb compliant' (which is the same as installing lsb --nodeps and ignoring everything, just that it won't be needed to be forced anymore)
Comment 7 Stephan Kulow 2019-02-12 12:44:12 UTC
Did that now - R.I.P. lsb
 -> created request id 673668
Comment 8 Swamp Workflow Management 2019-04-04 17:40:07 UTC
This is an autogenerated message for OBS integration:
This bug (1086166) was mentioned in
https://build.opensuse.org/request/show/691591 Factory / lsb