Bug 1085925 - Touchpad's right & middle buttons act like the left one
Touchpad's right & middle buttons act like the left one
Status: RESOLVED FEATURE
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: GNOME
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-03-19 21:40 UTC by Tommaso Fonda
Modified: 2018-04-14 18:23 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
Relevant output of some commands (2.64 KB, text/plain)
2018-03-19 21:40 UTC, Tommaso Fonda
Details
Dell XPS 13 9360 touchpad libinput (562 bytes, text/plain)
2018-03-22 11:34 UTC, Michiel Janssens
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tommaso Fonda 2018-03-19 21:40:59 UTC
Created attachment 764166 [details]
Relevant output of some commands

After installing the latest updates available for Tumbleweed, including Gnome 3.28, my laptop's touchpad's right and middle buttons all act like the left one, making it possible to use the touchpad only thanks to the two- and three-finger gestures, because otherwise a middle or right click would be impossible to perform. The laptop is an Asus X556UV, the touchpad is manufactured by Elan.
I face the problem both when using Gnome + Wayland and Gnome + Xorg, however the touchpad's buttons work properly in an IceWM session.
Comment 1 Michiel Janssens 2018-03-22 11:33:15 UTC
Exact same behavior on Dell XPS 13 9360. On openSUSE-release 20180319-1.2
External mouse works fine, only the touchpad has this issue.
Comment 2 Michiel Janssens 2018-03-22 11:34:03 UTC
Created attachment 764575 [details]
Dell XPS 13 9360 touchpad libinput
Comment 3 Bjørn Lie 2018-04-14 18:23:53 UTC
This is the expected behaviour now. Read link below for more info.

http://who-t.blogspot.no/2018/04/gnome-328-uses-clickfinger-behaviour-by.html

You may change it in gnome-control-center, devices, mouse and touchpad.