Bug 1085920 - devel:tools:scm/rabbitvcs: Dependency python2-simplejson missing in spec-file
devel:tools:scm/rabbitvcs: Dependency python2-simplejson missing in spec-file
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Development
Current
x86-64 openSUSE Factory
: P5 - None : Minor (vote)
: ---
Assigned To: Matthias Mailänder
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-03-19 21:04 UTC by Frank Voorburg
Modified: 2018-04-16 06:32 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Frank Voorburg 2018-03-19 21:04:31 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/64.0.3282.186 Safari/537.36
Build Identifier: 

The upstream project at https://github.com/rabbitvcs/rabbitvcs lists the following package in the system requirements: python-simplejson >= 2.1.1.

For openSUSE this translates to package python2-simplejson. This dependency is currently not listed in the package's rabbitvcs.spec file. 

It would be nice if this dependency could be added to the spec-file, because some things don't work properly unless this dependency is installed.

For example, I prefer to use double commander in combination with RabbitVCS for SVN operations. If doublecmd-gtk and rabbitvcs are installed, you should see the RabbitVCS related entries in double commander's context menu, after you right-click a directory. This currently only works properly after manually installing python2-simplejson.

Reproducible: Always

Steps to Reproduce:
1. Install doublecmd-gtk and rabbitvcs
2. Start double commander
3. Right-click a directory in double commander
Actual Results:  
The RabbitVCS related entries are not present in the context menu.

Expected Results:  
To see the RabbitVCS related entries in the context menu.
Comment 1 Matthias Mailänder 2018-04-15 15:37:47 UTC
https://build.opensuse.org/request/show/596745
Comment 2 Andreas Stieger 2018-04-16 06:32:05 UTC
looks straightforward enough