Bug 1085781 - nouveau bus MMIO write FAULT
nouveau bus MMIO write FAULT
Status: RESOLVED UPSTREAM
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kernel
Current
PC SUSE Other
: P5 - None : Minor (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-03-18 16:35 UTC by Andrew Wale
Modified: 2018-03-21 11:44 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Wale 2018-03-18 16:35:33 UTC
User-Agent:       Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0
Build Identifier: 

Cannot log in to system using GUI.

Log in from console terminal works (Ctrl Alt f1).

"dmesg" says
nouveau 0000:00:0d0: bus MMIO write of 00540001 FAULT at 00b000
plus a couple of other similar lines.

Occurs with Tumbleweed 20180314 installed by "zypper dup". Previous update a few days prior did not have this problem.

This is running on a 32-bit PC with an old graphics card.
"lspci |grep VGA" says
NVIDIA Corporation C61 [GeForce 6100 nForce 405] (rev a2)

Reproducible: Always

Steps to Reproduce:
1. Turn on PC
2. Attempt to log in
3.
Actual Results:  
login fails

Expected Results:  
login should succeed
Comment 1 Andrew Wale 2018-03-20 19:23:50 UTC
The workaround is to do a complete fresh install of Tumbleweed 20180316 which does not exhibit this problem.
Comment 2 Stefan Dirsch 2018-03-21 11:44:53 UTC
This sounds weird. Maybe by fresh installing the system you no longer install Mesa-dri-nouveau package, which you had installed before and the update to a newer Mesa version broke it. Mesa's nouveau driver has some special status ("It is packaged separately since it is still experimental"). Since I guess the old TW system is gone, all is speculation now. About nouveau driver status in general:

---
Nouveau is an experimental driver under constant heavy development.
This means that we cannot follow it closely, as we are not part of its team with reverse engineered knowledge of NVIDIA cards.

In case you wish to stick with nouveau and to help us improve its support in openSUSE, you can try our latest kernel, Mesa, and xf86-video-nouveau packages:

  http://kernel.opensuse.org/
  https://build.opensuse.org/package/show/X11:XOrg/Mesa
  https://build.opensuse.org/package/show/X11:XOrg/xf86-video-nouveau

Testing the latest versions is a prerequisite in order to inform nouveau's upstream developers of any bugs you find:

  https://nouveau.freedesktop.org/wiki/Bugs/

Once you are aware of an upstream fix for your issue, please reopen the bug and let us know. We will be happy to include it in your openSUSE distribution if it's technically feasible.

Alternatively, you can install NVIDIA's proprietary driver instead:

  https://en.opensuse.org/SDB:NVIDIA
---

In your case I'm afraid your hardware is no longer supported by NVIDIA's proprietary driver. :-(