Bug 1085772 - gdm 3.28 cannot start plasma session on Wayland
gdm 3.28 cannot start plasma session on Wayland
Status: RESOLVED FIXED
: 1085773 1085774 1085775 1085776 1085777 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: KDE Workspace (Plasma)
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-Mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-03-18 13:27 UTC by Roger Whittaker
Modified: 2018-03-19 18:41 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
logs showing the event (30.84 KB, text/plain)
2018-03-18 13:56 UTC, Roger Whittaker
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roger Whittaker 2018-03-18 13:27:32 UTC
With gdm version 3.28 selecting the (previously working) option for a plasma session on Wayland returns us to the gdm login screen.

$ cat /etc/os-release 
NAME="openSUSE Tumbleweed"
# VERSION="20180314"
ID=opensuse
ID_LIKE="suse"
VERSION_ID="20180314"
PRETTY_NAME="openSUSE Tumbleweed"
ANSI_COLOR="0;32"
CPE_NAME="cpe:/o:opensuse:tumbleweed:20180314"
BUG_REPORT_URL="https://bugs.opensuse.org"
HOME_URL="https://www.opensuse.org/"

$ rpm -q gdm                                                                                                                 
gdm-3.28.0-1.1.x86_64
Comment 1 Roger Whittaker 2018-03-18 13:49:40 UTC
I apologise for the duplicates - bugzilla was timing out and failing.
Comment 2 Roger Whittaker 2018-03-18 13:51:08 UTC
*** Bug 1085773 has been marked as a duplicate of this bug. ***
Comment 3 Roger Whittaker 2018-03-18 13:52:01 UTC
*** Bug 1085774 has been marked as a duplicate of this bug. ***
Comment 4 Roger Whittaker 2018-03-18 13:52:40 UTC
*** Bug 1085775 has been marked as a duplicate of this bug. ***
Comment 5 Roger Whittaker 2018-03-18 13:53:09 UTC
*** Bug 1085776 has been marked as a duplicate of this bug. ***
Comment 6 Roger Whittaker 2018-03-18 13:53:43 UTC
*** Bug 1085777 has been marked as a duplicate of this bug. ***
Comment 7 Roger Whittaker 2018-03-18 13:56:11 UTC
Created attachment 764062 [details]
logs showing the event
Comment 8 Neil Rickert 2018-03-18 17:10:46 UTC
Confirmed.

The only part that I cannot confirm, is the "previously working".  I have never been able to get to plasma-wayland using "gdm", though it works with "sddm".
Comment 9 Fabian Vogt 2018-03-18 21:59:56 UTC
It appears to me like this is a misunderstanding.
gdm already runs a dbus daemon for the session, but plasmawayland.desktop doesn't expect that. Instead, it contains:

Exec=dbus-launch --exit-with-session /usr/bin/startplasmacompositor

It's confirmed by https://bugzilla.gnome.org/show_bug.cgi?id=760613
However, it looks like the reporter never told upstream about this so it was never actually looked at.

Try to replace Exec= in /usr/share/wayland-sessions/plasmawayland.desktop with

Exec=dbus-run-session /usr/bin/startplasmacompositor

or, if that doesn't work,

Exec=/usr/bin/startplasmacompositor
Comment 10 Neil Rickert 2018-03-19 00:47:08 UTC
Replying to c#9 (Fabian Vogt):

Thank you.  Yes, that change fixed it.

Here's a diff for the change that I made:

--- plasmawayland.desktop       2018/03/19 00:02:02     1.1
+++ plasmawayland.desktop       2018/03/19 00:22:07     1.1.0.1
@@ -1,9 +1,9 @@
 [Desktop Entry]
 Encoding=UTF-8
-Exec=dbus-launch --exit-with-session /usr/bin/startplasmacompositor
+Exec=dbus-run-session /usr/bin/startplasmacompositor
 TryExec=/usr/bin/startplasmacompositor
 DesktopNames=KDE
-Name=Plasma
+Name=Plasma Wayland
 Name[ar]=بلازما
 Name[bs]=Plazma
 Name[ca]=Plasma

You will note that I also changed the name from "Plasma" to "Plasma Wayland".  That way, I can now recognize which entry is which in the GDM menu.  However, I did not try to change the name for other languages.

With that change, the entry shows up as "Plasma Wayland" and it works.

I also tested with "lightdm" and "sddm" for display-manager.  And it works there too.  Previously it did not work with "lightdm".

Using SDDM, there is now a superfluous "Wayland" in the name.  It now shows as something like "Plasma Wayland Session (Wayland)".
Comment 11 Fabian Vogt 2018-03-19 09:33:10 UTC
Fix landed upstream, will be part of 5.12.4 release.
Patch submitted to TW and Leap 15.0.
Comment 12 Roger Whittaker 2018-03-19 10:05:31 UTC
That worked for me, but with one or two problems.

 - After logging in I see a grey screen with mouse cursor until I do a Ctrl-Alt-F2.

 - After logging in display resolutions are wrong (apparently switched as between the two monitors that I'm using.

 - After logging in, middle mouse paste doesn't work (it did before when logging in to plasma on Wayland from gdm, which is why I was doing this, because the same was not true with sddm)

 - The name change doesn't show up for me (is it cached somewhere else?)
Comment 13 Fabian Vogt 2018-03-19 10:08:34 UTC
(In reply to Roger Whittaker from comment #12)
> That worked for me, but with one or two problems.
> 
>  - After logging in I see a grey screen with mouse cursor until I do a
> Ctrl-Alt-F2.
> 
>  - After logging in display resolutions are wrong (apparently switched as
> between the two monitors that I'm using.
> 
>  - After logging in, middle mouse paste doesn't work (it did before when
> logging in to plasma on Wayland from gdm, which is why I was doing this,
> because the same was not true with sddm)

Wayland does not support middle mouse paste (what GNOME does is a workaround, not actually clipboard vs. cutbuffer).
This means you were actually running an X11 session.

> 
>  - The name change doesn't show up for me (is it cached somewhere else?)
Comment 14 Swamp Workflow Management 2018-03-19 10:10:05 UTC
This is an autogenerated message for OBS integration:
This bug (1085772) was mentioned in
https://build.opensuse.org/request/show/588466 Factory / plasma5-workspace
https://build.opensuse.org/request/show/588467 15.0 / plasma5-workspace
Comment 15 Roger Whittaker 2018-03-19 10:16:30 UTC
In answer to comment#13 - with the old gdm (3.26) and plasma on Wayland I am as certain as I can be that middle mouse paste was working.  Did gdm previously apply that workaround somehow?

As noted above, lightdm also starts the session (and I don't see the problem with resolutions), but again the name change is not showing in the menu.
Comment 16 Neil Rickert 2018-03-19 15:10:08 UTC
The name change from my editing won't show up for a different language, such as UK English.  In any case, I'm not at all sure that's the right way to fix the name problem.  Maybe the X11 ".desktop" file should be changed to give a name "Plasma X11" or "Plasma Xorg".  That's for somebody to work out.  Think of my name change as an experiment.
Comment 17 Roger Whittaker 2018-03-19 15:44:45 UTC
Of course.  When I changed the [en_GB] version of it, it showed up correctly.

Regarding the middle mouse paste I can only assume that previously some gnome service was running that was allowing this for me.

Is there any way of enabling the gnome workaround on plasma on Wayland?