Bug 1084796 - Segmentation fault with zypper after zypper dup to TW20180305 and reboot on aarch64 (Raspberry Pi 3B)
Segmentation fault with zypper after zypper dup to TW20180305 and reboot on a...
Status: RESOLVED DUPLICATE of bug 1084812
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Basesystem
Current
aarch64 openSUSE Factory
: P5 - None : Normal with 3 votes (vote)
: ---
Assigned To: Andreas Schwab
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-03-10 22:24 UTC by Freek de Kruijf
Modified: 2018-03-19 03:26 UTC (History)
5 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Freek de Kruijf 2018-03-10 22:24:40 UTC
I used the image file openSUSE-Tumbleweed-ARM-JeOS-raspberrypi3.aarch64-2018.02.02-Build1.2.raw.xz to build a system om a Raspberry Pi 3B. After that I did a "zypper dup --no-recommends" to TW20180305 and installed a few other packages. After a reboot using zypper I get a Segmentation fault.
I also use "git clone" which does not give a clear error message, instead gives Cloning into 'xxxxx'..., however not even the folder xxxxx has been created.
I have a number of coredumps from git, a.o.:
/var/lib/systemd/coredump/core.git-remote-http.0.5701e233682d45d296fb928e88862f6c.1448.1520718889000000.lz4
Comment 1 Matthias Brugger 2018-03-12 11:45:36 UTC
Can you try what is describe in this link:
https://bugzilla.opensuse.org/show_bug.cgi?id=1084812#c5
Comment 2 Freek de Kruijf 2018-03-12 11:52:08 UTC
Added "195.135.221.134 download.opensuse.org" to /etc/hosts and the problem with zypper is gone.
Comment 3 Freek de Kruijf 2018-03-12 12:29:41 UTC
(In reply to Freek de Kruijf from comment #2)
> Added "195.135.221.134 download.opensuse.org" to /etc/hosts and the problem
> with zypper is gone.

Al least when doing "zypper se git". 

I got the 4 mentioned files in comment #5.
Installation succeeded after ignoring Signature verification. Also only two got installed from the rpm files, 3 others were downloaded.
Comment 4 Freek de Kruijf 2018-03-12 12:46:53 UTC
(In reply to Freek de Kruijf from comment #3)
> (In reply to Freek de Kruijf from comment #2)
> > Added "195.135.221.134 download.opensuse.org" to /etc/hosts and the problem
> > with zypper is gone.
> 
> Al least when doing "zypper se git". 
> 
> I got the 4 mentioned files in comment #5.
> Installation succeeded after ignoring Signature verification. Also only two
> got installed from the rpm files, 3 others were downloaded.

Apparently the downloaded ones did not get installed. After a reboot 4 packages came from obs://build.opensuse.org/home:StefanBruens
Comment 5 Freek de Kruijf 2018-03-12 12:59:52 UTC
I installed python2-pip, but the command "pip > /dev/null" segfaults.
Comment 6 Andreas Färber 2018-03-19 03:26:47 UTC
Let's consolidate the information where the most details are.

*** This bug has been marked as a duplicate of bug 1084812 ***