Bug 1084644 - GCC 8: zypper build fails
GCC 8: zypper build fails
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: libzypp
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks: 1084649
  Show dependency treegraph
 
Reported: 2018-03-09 10:05 UTC by Martin Liška
Modified: 2018-03-15 10:08 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Liška 2018-03-09 10:05:35 UTC
Build the package with GCC 8, there's error:

[  227s] /home/abuild/rpmbuild/BUILD/zypper-1.14.2/src/callbacks/rpm.h:124:37: error: could not convert '(zypp::sat::asSolvable)(val_r)' from 'zypp::sat::asSolvable' to 'zypp::sat::Solvable'

Please build the project as follows to reproduce the issue:
osc build --alternative-project=openSUSE:Factory:Staging:Gcc7
Comment 1 Michael Andres 2018-03-15 10:08:29 UTC
This is fixed since zypper-1.14.3. 
(https://github.com/openSUSE/zypper/issues/146)