Bug 1084638 - GCC 8: systemd build fails
GCC 8: systemd build fails
Status: RESOLVED FIXED
: 1084641 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Basesystem
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: systemd maintainers
E-mail List
:
Depends on:
Blocks: 1084649
  Show dependency treegraph
 
Reported: 2018-03-09 10:03 UTC by Martin Liška
Modified: 2018-03-25 08:25 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Liška 2018-03-09 10:03:52 UTC
Build the package with GCC 8, there's error:

[  121s] ../src/udev/udev-builtin-hwdb.c:79:38: error: ‘%04X’ directive output may be truncated writing between 4 and 8 bytes into a region of size between 2 and 6 [-Werror=format-truncation=]

Please build the project as follows to reproduce the issue:
osc build --alternative-project=openSUSE:Factory:Staging:Gcc7
Comment 1 Franck Bui 2018-03-15 16:32:01 UTC
*** Bug 1084641 has been marked as a duplicate of this bug. ***
Comment 2 Franck Bui 2018-03-25 08:25:16 UTC
5547c12503a683290eaed47954ffcfb2d1bc03cd which fixes this build issue backported in SUSE/v237 branch (only).

Closing.