Bug 1084630 - GCC 8: libstoragemgmt build fails
GCC 8: libstoragemgmt build fails
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Basesystem
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: nick wang
E-mail List
:
Depends on:
Blocks: 1084649
  Show dependency treegraph
 
Reported: 2018-03-09 10:01 UTC by Martin Liška
Modified: 2018-04-17 05:01 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
Full build error log for format-truncation (11.75 KB, text/plain)
2018-03-27 07:57 UTC, nick wang
Details
python_c error after fixing format-truncation (6.56 KB, text/plain)
2018-03-27 07:58 UTC, nick wang
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Liška 2018-03-09 10:01:09 UTC
Build the package with GCC 8, there's error:

[   58s] libsg.c:560:34: error: '%s' directive output may be truncated writing up to 1023 bytes into a region of size 983 [-Werror=format-truncation=]

Please build the project as follows to reproduce the issue:
osc build --alternative-project=openSUSE:Factory:Staging:Gcc7
Comment 1 nick wang 2018-03-27 07:57:31 UTC
Created attachment 765011 [details]
Full build error log for format-truncation
Comment 2 nick wang 2018-03-27 07:58:17 UTC
Created attachment 765012 [details]
python_c error after fixing format-truncation
Comment 3 nick wang 2018-03-27 08:00:10 UTC
An pr [1] in upstream for [-Werror=format-truncation=] against gcc8, not merged yet.

[1] https://github.com/libstorage/libstoragemgmt/pull/331
Comment 4 nick wang 2018-04-03 04:47:50 UTC
The pr mentioned in Comment#3 is still open.
The patch passed the test on obs, will submit as long as the pr is merged.
Comment 5 nick wang 2018-04-11 09:06:50 UTC
The pr in upstream still pending due to the failure of ontap plugin. So backport the gcc8 fix only to factory in https://build.opensuse.org/request/show/595526
Comment 6 nick wang 2018-04-17 05:01:23 UTC
Change to resolved/fixed, since openSUSE:Factory accepted the fix.