Bug 1084620 - GCC 8: kernel-vanilla build fails
GCC 8: kernel-vanilla build fails
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Basesystem
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Michal Suchanek
E-mail List
:
Depends on:
Blocks: 1084649
  Show dependency treegraph
 
Reported: 2018-03-09 09:33 UTC by Martin Liška
Modified: 2022-07-21 17:21 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Liška 2018-03-09 09:33:37 UTC
Build the package with GCC 8, there's error:

kernel-vanilla.log:[   92s] pager.c:36:12: error: passing argument 2 to restrict-qualified parameter aliases with argument 4 [-Werror=restrict]

Please build the project as follows to reproduce the issue:
osc build --alternative-project=openSUSE:Factory:Staging:Gcc7
Comment 1 Michal Suchanek 2018-03-15 17:57:21 UTC
On the other hand master build works for me. The vanilla branch often contains intermittent errors because it merges bleeding edge git snapshots so I am not overly concerned.
Comment 2 Martin Liška 2018-03-27 15:24:57 UTC
Pending patch is here, please backport it after it will land:
https://lkml.org/lkml/2018/3/19/24
Comment 3 Michal Suchanek 2018-03-27 17:38:51 UTC
Thanks for reporting the fix

It will get into vanilla automatically when it lands but may be needed in master eventually.
Comment 4 Michal Suchanek 2018-04-19 16:59:46 UTC
Merged into master branch