Bug 1084607 - No sound in earphone
No sound in earphone
Status: RESOLVED DUPLICATE of bug 1084047
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Sound
Current
x86-64 openSUSE Factory
: P5 - None : Major (vote)
: ---
Assigned To: Takashi Iwai
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-03-09 07:55 UTC by Tamás Németh
Modified: 2018-03-09 07:57 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tamás Németh 2018-03-09 07:55:35 UTC
I have a Dell Latitude E5450 laptop with the following sound hardware:

netadmin:~ # lspci | grep -i audio
00:03.0 Audio device: Intel Corporation Broadwell-U Audio Controller (rev 09)
00:1b.0 Audio device: Intel Corporation Wildcat Point-LP High Definition Audio Controller (rev 03)

The audio driver seems to be snd_hda_intel. I run a fully up-to-date OpenSUSE Tumbleweed x86-64 system on this computer. I don't know if it's because of some recent kernel update or pulseaudio update, but anyway, I observed that I have no audio via earphones. I can hear the sound via the builtin speakers when my earphones are unplugged, but when I plug them in, the sound stops.

It's important to note that when I'm watching a youtube video in firefox with unplugged earphones, then the video immediately stops when I plug in the earphones!!! Firefox may somehow detect that it can't send the audio stream to pulseaudio anymore!

If I run pavucontrol-qt, and go to the output devices tab, and then plug in the earphones, then it tries to switch view(?) by displaying "Establishing connection to PulseAudio. Please wait...", but it falls back to speakers in one or two seconds :-(
Comment 1 Takashi Iwai 2018-03-09 07:57:26 UTC
The fix should be released soon.

*** This bug has been marked as a duplicate of bug 1084047 ***