Bug 1084478 - Okular cannot load CBR files with unar installed (tumbleweed wants unar)
Okular cannot load CBR files with unar installed (tumbleweed wants unar)
Status: RESOLVED DUPLICATE of bug 1083834
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: KDE Applications
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-Mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-03-08 10:34 UTC by Markus Zimmermann
Modified: 2018-03-10 08:34 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Markus Zimmermann 2018-03-08 10:34:31 UTC
I am using Tumbleweed 20180306 (and at least some versions before that did not work either)

When I open a CBR file with okular I receive the message "No unrar detected." if "unar" is installed.

The thing is, that tumbleweed wants "unar" and not "unrar" installed. On the next "zypper up" I get the suggestion to remove unrar and install unar.
Comment 1 Wolfgang Bauer 2018-03-08 14:36:19 UTC
That's not a bug in Okular though.

unar comes with an "unrar" wrapper script but that is incompatible to unrar.
And this also breaks ark e.g.

*** This bug has been marked as a duplicate of bug 1083834 ***
Comment 2 Wolfgang Bauer 2018-03-08 14:41:41 UTC
(In reply to Wolfgang Bauer from comment #1)
> *** This bug has been marked as a duplicate of bug 1083834 ***

At least I think it is the same problem...
Comment 3 Markus Zimmermann 2018-03-10 08:34:49 UTC
Thank you. Yes, that must be the same problem. I am currently locking that "unrar" package so that "unar" does not get installed.