Bug 1084343 - [Containers] bundle not found
[Containers] bundle not found
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kubic
Current
Other Other
: P2 - High : Major (vote)
: ---
Assigned To: Containers Team
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-03-07 16:10 UTC by Richard Brown
Modified: 2018-03-30 21:11 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Brown 2018-03-07 16:10:38 UTC
On a Kubic Admin node, velum-api, velum-dashboard, and velum-event-processor (and possibly any other velum related container using ruby fail with errors akin to

`bundle: command not found`

This seems to be because all are looking (often via a /bin/bundle symlink) for ruby 2.1.0 versions of bundle, whereas all Kubic images have ruby 2.5.0 at the moment
Comment 1 Rafael Fernández López 2018-03-20 12:43:41 UTC
Tentative PR to fix this issue on any ruby version: https://github.com/kubic-project/container-images/pull/11

Needs some further checking.