Bug 1084203 - YaST:Head/yast2-hardware-detection: TW installer does not see USB SSD
YaST:Head/yast2-hardware-detection: TW installer does not see USB SSD
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: YaST2
Current
Other Other
: P5 - None : Normal (vote)
: Current
Assigned To: E-mail List
Jiri Srain
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-03-06 20:21 UTC by Rafael Kitover
Modified: 2018-03-12 07:58 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rafael Kitover 2018-03-06 20:21:41 UTC
I tried to use the latest tumbleweed installer a couple of days ago to install tumbleweed to a USB SSD.

The "Guided Partitioner" would not show the SSD as an option.

The "Expert Partitioner" died on me with a ruby bug, on line 91 in:

/usr/share/YaST2/lib/y2storage/hwinfo_reader.rb

something about "cannot call each on nil::NilClass"

I was able to install Fedora onto the SSD fine, it was detected correctly.
Comment 1 Martin Vidner 2018-03-07 12:36:42 UTC
Thanks for the report.

Please attach the YaST logs so that we can see the details of the involved hardware and pinpoint the problem.

https://en.opensuse.org/openSUSE:Report_a_YaST_bug
Comment 2 Rafael Kitover 2018-03-12 07:58:15 UTC
I just tried it again yesterday with the current TW netinstall image, and the bug is no longer there, it correctly displays all USB disks in the expert partitioner.