Bug 1083902 - pkg-config of libtiprc reports non-existent path
pkg-config of libtiprc reports non-existent path
Status: RESOLVED FIXED
: 1086394 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Basesystem
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Thorsten Kukuk
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-03-05 08:19 UTC by Andreas Schneider
Modified: 2018-04-05 10:50 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Schneider 2018-03-05 08:19:30 UTC
As SUSE decided to move the header files for tiprc, it should reflect that in the pkg-config file!

magrathea:~ # pkg-config --cflags libtirpc
-I/usr/include/tirpc
magrathea:~ # ll /usr/include/tirpc
ls: cannot access '/usr/include/tirpc': No such file or directory
Comment 1 Thorsten Kukuk 2018-03-05 10:55:53 UTC
(In reply to Andreas Schneider from comment #0)
> As SUSE decided to move the header files for tiprc, it should reflect that
> in the pkg-config file!

Beside that other distributions did this already or will do the same, What's the problem?
Comment 2 Andreas Schneider 2018-03-05 11:12:50 UTC
The libtirpc detection in Samba doesn't work on openSUSE. It works just fine on Fedora because the rpc headers are in /usr/include/tirpc. Currently it assumes if the rpc.h header is /usr/include/rpc/rpc.h that glibc supports it. If it isn't there it looks for libtirpc. But as SUSE decided to move the header to its original location, the configure checks needs to be extended to cover this correctly.
Comment 3 Thorsten Kukuk 2018-03-05 12:14:40 UTC
(In reply to Andreas Schneider from comment #2)
> The libtirpc detection in Samba doesn't work on openSUSE. It works just fine
> on Fedora because the rpc headers are in /usr/include/tirpc.

Ok, but that it works on Fedora is only a matter of time, they are planning to do the same changes as we do to replace sunrpc in glibc with tirpc.
Comment 4 Andreas Schneider 2018-03-05 12:24:16 UTC
Fedora moved to libtirpc and rpcsvc-proto already several weeks ago. Samba has been changed to work with the old glibc headers and libtirpc.
Comment 5 Thorsten Kukuk 2018-03-05 12:56:57 UTC
(In reply to Andreas Schneider from comment #4)
> Fedora moved to libtirpc and rpcsvc-proto already several weeks ago.
 
I know, they copied part of our code and patches from our move.
Comment 6 Thorsten Kukuk 2018-03-22 07:28:04 UTC
*** Bug 1086394 has been marked as a duplicate of this bug. ***