Bug 1083853 - Xorg crash, scrolling in Firefox, Intel graphics
Xorg crash, scrolling in Firefox, Intel graphics
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: X.Org
Current
x86-64 openSUSE Factory
: P3 - Medium : Major (vote)
: ---
Assigned To: Jan Engelhardt
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-03-04 00:22 UTC by S. B.
Modified: 2018-03-21 07:53 UTC (History)
6 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---
sndirsch: needinfo? (sb56637)


Attachments
Xorg.0.log.old after the crash (70.04 KB, application/x-trash)
2018-03-04 00:22 UTC, S. B.
Details
hwinfo (461.77 KB, text/plain)
2018-03-04 00:23 UTC, S. B.
Details

Note You need to log in before you can comment on or make changes to this bug.
Description S. B. 2018-03-04 00:22:51 UTC
Created attachment 762600 [details]
Xorg.0.log.old after the crash

Hi, this bug has happened twice now. As I'm randomly scrolling upwards in Firefox, Xorg crashes and I get dumped back to the login screen. This is on a Thinkpad T530 laptop with Intel i915 graphics, but using the X modesetting driver. I think I managed to capture logs of the crash (Xorg.0.log.old) which I am attaching.
Comment 1 S. B. 2018-03-04 00:23:36 UTC
Created attachment 762601 [details]
hwinfo
Comment 2 Stefan Dirsch 2018-03-04 13:20:44 UTC
abort() in libinput? Wow!

[ 15432.133] (II) Axis 0x1 value 4758 is outside expected range [1253, 4652]
See https://wayland.freedesktop.org/libinput/doc/1.10.0//absolute_coordinate_ranges.html for details
[ 18613.697] (II) Axis 0x1 value 4829 is outside expected range [1253, 4652]
See https://wayland.freedesktop.org/libinput/doc/1.10.0//absolute_coordinate_ranges.html for details
[ 22477.424] (II) Axis 0x1 value 1213 is outside expected range [1253, 4652]
See https://wayland.freedesktop.org/libinput/doc/1.10.0//absolute_coordinate_ranges.html for details
[ 32511.323] (II) Axis 0x1 value 1247 is outside expected range [1253, 4652]
See https://wayland.freedesktop.org/libinput/doc/1.10.0//absolute_coordinate_ranges.html for details
[ 42996.800] (II) Axis 0x1 value 4728 is outside expected range [1253, 4652]
See https://wayland.freedesktop.org/libinput/doc/1.10.0//absolute_coordinate_ranges.html for details
[ 51441.879] (II) Axis 0x1 value 4714 is outside expected range [1253, 4652]
See https://wayland.freedesktop.org/libinput/doc/1.10.0//absolute_coordinate_ranges.html for details
[ 54536.485] (II) Axis 0x1 value 4819 is outside expected range [1253, 4652]
See https://wayland.freedesktop.org/libinput/doc/1.10.0//absolute_coordinate_ranges.html for details
[ 60045.882] (II) Axis 0 value 1270 is outside expected range [1272, 5669]
See https://wayland.freedesktop.org/libinput/doc/1.10.0//absolute_coordinate_ranges.html for details
[ 63631.526] (II) Axis 0x1 value 1213 is outside expected range [1253, 4652]
See https://wayland.freedesktop.org/libinput/doc/1.10.0//absolute_coordinate_ranges.html for details
[ 71160.395] (II) Axis 0x1 value 4833 is outside expected range [1253, 4652]
See https://wayland.freedesktop.org/libinput/doc/1.10.0//absolute_coordinate_ranges.html for details
[ 77634.560] (II) Axis 0x1 value 1240 is outside expected range [1253, 4652]
See https://wayland.freedesktop.org/libinput/doc/1.10.0//absolute_coordinate_ranges.html for details
[ 80723.316] (II) Axis 0x1 value 4668 is outside expected range [1253, 4652]
See https://wayland.freedesktop.org/libinput/doc/1.10.0//absolute_coordinate_ranges.html for details
[ 83740.390] (II) Axis 0x1 value 4834 is outside expected range [1253, 4652]
See https://wayland.freedesktop.org/libinput/doc/1.10.0//absolute_coordinate_ranges.html for details
[ 87715.610] (II) Axis 0x1 value 4653 is outside expected range [1253, 4652]
See https://wayland.freedesktop.org/libinput/doc/1.10.0//absolute_coordinate_ranges.html for details
[ 90995.560] (II) Axis 0x1 value 4792 is outside expected range [1253, 4652]
See https://wayland.freedesktop.org/libinput/doc/1.10.0//absolute_coordinate_ranges.html for details
[101212.892] (II) Axis 0x1 value 4767 is outside expected range [1253, 4652]
See https://wayland.freedesktop.org/libinput/doc/1.10.0//absolute_coordinate_ranges.html for details
[103829.448] (EE) 
[103829.448] (EE) Backtrace:
[103829.462] (EE) 0: /usr/bin/X (xorg_backtrace+0x65) [0x555fdf2673f5]
[103829.462] (EE) 1: /usr/bin/X (0x555fdf0b2000+0x1b91a9) [0x555fdf26b1a9]
[103829.462] (EE) 2: /lib64/libpthread.so.0 (0x7f493d07c000+0x12270) [0x7f493d08e270]
[103829.462] (EE) 3: /lib64/libc.so.6 (gsignal+0x110) [0x7f493ccf80d0]
[103829.462] (EE) 4: /lib64/libc.so.6 (abort+0x151) [0x7f493ccf96b1]
[103829.462] (EE) 5: /lib64/libc.so.6 (0x7f493ccc2000+0x2e6fa) [0x7f493ccf06fa]
[103829.462] (EE) 6: /lib64/libc.so.6 (0x7f493ccc2000+0x2e772) [0x7f493ccf0772]
[103829.462] (EE) 7: /usr/lib64/libinput.so.10 (0x7f4935b7f000+0x1ec0e) [0x7f4935b9dc0e]
[103829.462] (EE) 8: /usr/lib64/libinput.so.10 (0x7f4935b7f000+0x1a077) [0x7f4935b99077]
[103829.462] (EE) 9: /usr/lib64/libinput.so.10 (0x7f4935b7f000+0x1bfb0) [0x7f4935b9afb0]
[103829.462] (EE) 10: /usr/lib64/libinput.so.10 (0x7f4935b7f000+0x10881) [0x7f4935b8f881]
[103829.462] (EE) 11: /usr/lib64/libinput.so.10 (libinput_dispatch+0x5f) [0x7f4935b8b87f]
[103829.462] (EE) 12: /usr/lib64/xorg/modules/input/libinput_drv.so (0x7f4935dba000+0x9078) [0x7f4935dc3078]
[103829.462] (EE) 13: /usr/bin/X (0x555fdf0b2000+0x1b7583) [0x555fdf269583]
[103829.463] (EE) 14: /usr/bin/X (0x555fdf0b2000+0x1b9c81) [0x555fdf26bc81]
[103829.463] (EE) 15: /usr/bin/X (0x555fdf0b2000+0x1b73ce) [0x555fdf2693ce]
[103829.463] (EE) 16: /lib64/libpthread.so.0 (0x7f493d07c000+0x7558) [0x7f493d083558]
[103829.463] (EE) 17: /lib64/libc.so.6 (clone+0x3f) [0x7f493cdba72f]
[103829.463] (EE) 
[103829.463] (EE) 
Fatal server error:
[103829.463] (EE) Caught signal 6 (Aborted). Server aborting
[103829.463] (EE) 
[103829.465] (EE)
Comment 3 Jan Engelhardt 2018-03-04 14:06:09 UTC
You could try X11:Wayland/libinput-1.10.1 whichi is said to have some crashes fixed.
Comment 4 S. B. 2018-03-04 19:16:04 UTC
Hmm OK, but it seems strange that this bug just started to happen, when I've been using this same system and configuration for years.

Also, why "X11:Wayland/libinput" and all of the Wayland documentation links if I'm not using a Wayland compositor?
Comment 5 Jan Engelhardt 2018-03-04 19:24:13 UTC
(In reply to S. B. from comment #4)
> Hmm OK, but it seems strange that this bug just started to happen, when I've
> been using this same system and configuration for years.

That's impossible - libinput 1.10 only exists since Feb 13, so you cannot have had that kind of system before ;-)

> Also, why "X11:Wayland/libinput" and all of the Wayland documentation links
> if I'm not using a Wayland compositor?

It just evolved that way.
Comment 6 Stefan Dirsch 2018-03-04 21:14:16 UTC
 S. B., just as background. We switched to xf86-input-libinput driver, which then uses libinput. As workaround you can also synaptics driver (install xf86-input-synaptics package for doing this). Unfortunately other drivers than libinput drivers are no longer in development and current desktops limit configuration UIs to libinput driver.
Comment 7 S. B. 2018-03-04 21:22:48 UTC
Thanks for the reply Stefan, yes, I had to switch from Synaptics to libinput because my desktop environment (Cinnamon) needs it.

Is the [NEEDINFO] flag related to me testing libinput-1.10.1 ? Would it be this one?
https://download.opensuse.org/repositories/X11:/Wayland/openSUSE_Tumbleweed/x86_64/libinput10-1.10.1-152.1.x86_64.rpm
Comment 8 Stefan Dirsch 2018-03-04 21:31:53 UTC
Yes, yes. :-) That's it!
Comment 9 S. B. 2018-03-04 23:17:16 UTC
OK, I'll test it out and let you know. The problem is that this bug has happened twice, but it's not always repeatable, or at least I can't figure out the circumstances to repeat it.
Comment 10 Michal Srb 2018-03-05 10:29:36 UTC
(In reply to S. B. from comment #9)
> The problem is that this bug has happened twice, but it's not always
> repeatable, or at least I can't figure out the circumstances to repeat it.

From the log messages I guess that it could be triggered by touching very close to the left/right/top/bottom edge of a touchpad.
Comment 11 Giuseppe Salinaro 2018-03-14 00:53:53 UTC
I have the same issue.Now i'm on the tumbleweed 20180312 without 
libinput-udev
plasma5-session-wayland
xf86-input-libinput
and no crash

Searching on internet other distro have problem with libinput 1.10.x and revert to 1.9 fixing the issue
Comment 12 Stefan Dirsch 2018-03-14 09:41:39 UTC
Sounds like a git bisect job - if reproducable ...
Comment 13 Jan Engelhardt 2018-03-14 09:48:56 UTC
Upstream has made available another crash bugfix release. Perhaps 1.10.3 from the same repo addresses your issue this time - please check it out.
Comment 14 Giuseppe Salinaro 2018-03-15 14:18:34 UTC
I upgrade to libinput to 1.10.3 from the wayland repo. I used the touchpad for 3 hours and nothing happened. Opensuse tumbleweed 20180313
Comment 15 Stefan Dirsch 2018-03-15 14:27:31 UTC
(In reply to Giuseppe Salinaro from comment #14)
> I upgrade to libinput to 1.10.3 from the wayland repo. I used the touchpad
> for 3 hours and nothing happened. Opensuse tumbleweed 20180313

You have reinstalled the packages from your comment#11 and restarted your graphical session, right?
Comment 16 Giuseppe Salinaro 2018-03-15 14:37:25 UTC
Yes i do zypper dup and reinstall the packages on comment 11 and reboot.
After i only upgrade libinput10 and libinput10-udev from the wayland repo without change vendors and reboot.
Comment 17 S. B. 2018-03-15 14:54:10 UTC
It was *REALLY* bad for me yesterday with libinput10-1.10.2 from the TW repo after a normal set of upgrades, constant crashes. Now that I manually updated it to X11:Wayland/libinput10-1.10.3 I haven't had any crashes, but it's too soon to say for sure.
Comment 20 Dominique Leuenberger 2018-03-20 15:21:12 UTC
libinput -> Jan
Comment 21 Jan Engelhardt 2018-03-21 07:53:30 UTC
5 days without a report, seems like it may be good now.