Bug 1083835 - clusterssh doc generation is racy
clusterssh doc generation is racy
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
Other openSUSE Factory
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-03-03 13:51 UTC by Bernhard Wiedemann
Modified: 2018-03-13 01:36 UTC (History)
1 user (show)

See Also:
Found By: Development
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bernhard Wiedemann 2018-03-03 13:51:01 UTC
Sometimes (~30% of cases) when building clusterssh packages with -j4
it incorrectly generates the doc that goes into scripts

See http://rb.zq1.de/compare.factory-20180228/clusterssh-compare.out
for an example diff.

This happens because every output file is generated 6 times - in parallel.

In addition to generating incorrect packages,
it also makes the package build unreproducible as described in
https://github.com/bmwiedemann/theunreproduciblepackage/tree/master/race
Comment 1 Jan Engelhardt 2018-03-03 14:42:10 UTC
Switching to -j1.
Comment 2 Swamp Workflow Management 2018-03-03 16:40:07 UTC
This is an autogenerated message for OBS integration:
This bug (1083835) was mentioned in
https://build.opensuse.org/request/show/582218 Factory / clusterssh
Comment 3 Bernhard Wiedemann 2018-03-04 11:15:56 UTC
now that sourceforge is back, I filed it upstream at
https://sourceforge.net/p/clusterssh/support-requests/55/

Not sure if that is the right place, though.
Comment 4 Bernhard Wiedemann 2018-03-13 01:36:20 UTC
and opened
https://github.com/duncs/clusterssh/pull/106