Bug 1083832 - osc shows multibuild status even when there is no multibuild
osc shows multibuild status even when there is no multibuild
Status: NEW
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Development
Current
x86-64 Linux
: P5 - None : Normal (vote)
: ---
Assigned To: Marcus Hüwe
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-03-03 11:58 UTC by Jan Engelhardt
Modified: 2018-03-04 22:07 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Engelhardt 2018-03-03 11:58:18 UTC
[build.opensuse.org home:jengelh:branches:ical3]

12:56 a4:../ical3/libical > rpm -q osc
osc-0.162.1-1.1.noarch
12:55 a4:../ical3/libical > l
total 892
drwxr-xr-x  5 jengelh users    178 Mar  3 12:55 .
drwxr-xr-x 91 jengelh users   4096 Mar  3 12:50 ..
drwxr-xr-x 12 jengelh users   4096 Mar  3 11:41 libical
drwxr-xr-x 12 jengelh users   4096 Mar  3 11:38 libical-3.0.3
drwxr-xr-x  2 jengelh users   4096 Mar  3 12:55 .osc
-rw-r--r--  1 jengelh users      9 Mar  3 12:51 baselibs.conf
-rw-r--r--  1 jengelh users 866624 Feb 27 17:10 libical-3.0.3.tar.gz
-rw-r--r--  1 jengelh users  14944 Mar  3 12:54 libical.changes
-rw-r--r--  1 jengelh users   3431 Mar  3 12:54 libical.spec
12:56 a4:../ical3/libical > osc r
openSUSE_Factory     i586       libical                        building
openSUSE_Factory     i586       libical-2_0                    succeeded*
openSUSE_Factory     x86_64     libical                        building
openSUSE_Factory     x86_64     libical-2_0                    succeeded*


Expected result:
Because there is no _multibuild, let alone multiple .spec files, it should just show:

12:56 a4:../ical3/libical > osc r
openSUSE_Factory     i586       libical                        building
openSUSE_Factory     x86_64     libical                        building
Comment 1 Marcus Hüwe 2018-03-04 22:07:45 UTC
Hrm you could use "osc r --no-multibuild ..." as a workaround. Maybe we should
add a "osc r --no-locallink ..." option so that the "locallink" feature is
disabled.