Bug 1082512 - yast / yast 2 -> Software did not start: Failed to load Module 'Packages' due to: Failed to load Module 'SpaceCalculation'
yast / yast 2 -> Software did not start: Failed to load Module 'Packages' due...
Status: RESOLVED DUPLICATE of bug 1078715
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: YaST2
Current
x86-64 openSUSE Factory
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
Jiri Srain
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-23 10:09 UTC by Karl Maier
Modified: 2018-02-27 18:59 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---
ancor: needinfo? (m-karl-77)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Karl Maier 2018-02-23 10:09:32 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Build Identifier: 

Starting yast or yast2 and then selecting Software -> Software Management results in this Error-Message:

+-------------------------------------------------------------------------------------------+
¦Error                                                                                      ¦
¦Internal error. Please report a bug report with logs.                                      ¦
¦Run save_y2logs to get complete logs.                                                      ¦
¦Details: Failed to load Module 'Packages' due to: Failed to load Module 'SpaceCalculation' ¦
¦Caller:  /usr/lib64/ruby/2.4.0/rubygems/core_ext/kernel_require.rb:55:in `require'         ¦
¦                                                                                           ¦
¦                                           [OK]                                            ¦
+-------------------------------------------------------------------------------------------+



Reproducible: Always

Steps to Reproduce:
1. Start yast
2. Select Software
3. Select Software Management
Actual Results:  
The Error Message appears and yast stops working


I have run save_y2logs... but where can I upload the file?
Comment 1 Karl Maier 2018-02-23 10:15:03 UTC
1. I selected openSuSE Factory, because there has been no "Tubleweed"
2. I tried to upload the Result of save_y2logs, but it ends in an Error too. (a cgi couldnt be accessed or so)
Comment 2 Karl Maier 2018-02-23 10:18:16 UTC
The complete Attachment-Upload-Error-Message is:

----8<-------8<-------8<-------8<-------8<---
Zugriff auf die Datei wurde verweigert

Die Datei auf https://bugzilla.opensuse.org/attachment.cgi ist nicht lesbar.

    Sie wurde möglicherweise entfernt, verschoben, oder Dateiberechtigungen könnten den Zugriff verhindern.
----8<-------8<-------8<-------8<-------8<---
Comment 3 Ancor Gonzalez Sosa 2018-02-27 15:19:56 UTC
It doesn't look like there is a general problem attaching stuff to bugzilla. We are getting bug reports with correct attachments at good pace. :-) So looks like the problem is in your side.

Anyway, it would be already quite useful if you can paste here the lines from /var/log/YaST/y2log around the one which reads
"Failed to load Module 'Packages' due to: Failed to load Module 'SpaceCalculation'".

Let's say 50 lines in total, starting 25 lines before that one.
Comment 4 Ancor Gonzalez Sosa 2018-02-27 15:29:25 UTC
That being said. This looks like a possible duplicate of bug#1078715. Are you sure your system is fully up-to-date (zypper dup).
Comment 5 Karl Maier 2018-02-27 18:59:06 UTC
Yes, you're right, zypper dup solved the problem. I'm very sorry, the last times, I only updated via the GUI-Update-Option.

*** This bug has been marked as a duplicate of bug 1078715 ***