Bug 1082386 - Yast2 bootloader module: "Probing device relationships failed"
Yast2 bootloader module: "Probing device relationships failed"
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: YaST2
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: YaST Team
Jiri Srain
https://trello.com/c/ahYtYV79/
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-22 19:07 UTC by Hadrien Grasland
Modified: 2018-03-07 14:07 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
Output of save_y2logs (6.35 MB, application/x-xz)
2018-02-22 19:07 UTC, Hadrien Grasland
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hadrien Grasland 2018-02-22 19:07:19 UTC
Created attachment 761319 [details]
Output of save_y2logs

If I run the bootloader module of Yast2 on current Tumbleweed, I get:

| Error                                                                     │                                       │ Internal error. Please report a bug report with logs.                     │
│ Run save_y2logs to get complete logs.                                     │
│ Details: Storage::Exception                                               │
│ Caller:  /usr/share/YaST2/lib/y2storage/storage_manager.rb:132:in `probe' |

The corresponding y2logs are attached.
Comment 1 Ancor Gonzalez Sosa 2018-02-27 15:13:00 UTC
Added to the card where we are collecting these probing errors for a first evaluation https://trello.com/c/suEMHOu

We will update this bug report with the findings.
Comment 2 Hadrien Grasland 2018-02-27 17:57:42 UTC
With the latest TW updates, the original internal error is gone, and I now get a recoverable error instead (pardon my French):

│ Probing device relationships failed │
│                                     │
│ device not found, name:/dev/loop0   │
│                                     │
│ Continuer malgré l'erreur ?         │ 
│                                     │
│      [Continuer] [Abandonner]       │ 

Selecting "Continue" gets me into bootloader configuration as before.

So for me, the original error is partially fixed, and the new one is less problematic, that's a step forward! :)

By the way, I cannot access the Trello card which you linked to for some reason...
Comment 3 Ancor Gonzalez Sosa 2018-02-28 09:08:05 UTC
That second error looks to my like a duplicate of bug#1082143. That should be fixed in libstorage-ng >= 3.3.170.

Feel free to reopen if the system you are using has a newer version of that package.

*** This bug has been marked as a duplicate of bug 1082143 ***
Comment 4 Hadrien Grasland 2018-02-28 13:45:18 UTC
Sadly, it seems that this specific problem is still around with libstorage-ng 3.3.173. Should I reopen this ticket or bug#1082143?
Comment 5 Ancor Gonzalez Sosa 2018-02-28 14:08:48 UTC
(In reply to Hadrien Grasland from comment #4)
> hould I reopen this ticket or bug#1082143?

This one. I'm doing it.
Comment 6 Ancor Gonzalez Sosa 2018-03-01 08:48:12 UTC
Arvin. Any obvious thing that comes to your mind?
Comment 7 Arvin Schnell 2018-03-01 09:20:40 UTC
Yes, LUKS on loop-device. I have to improve that LUKS detection with
multipath anyway.
Comment 8 Ancor Gonzalez Sosa 2018-03-01 09:41:00 UTC
(In reply to Arvin Schnell from comment #7)
> Yes, LUKS on loop-device. I have to improve that LUKS detection with
> multipath anyway.

Ok. Added to the same Trello card the YaST Team is using to track the LUKS on multipath issue.
Comment 9 Arvin Schnell 2018-03-07 14:07:28 UTC
Now libstorage-ng version 3.3.186 only sees LUKSes on block devices it
already knows. Since it does not know about loop devices the LUKS is also
not seen.