Bug 1082226 - [Build 20180221] Internal error triggered on offline upgrades when selecting the "Booting" section - No such file or directory @ rb_sysopen - /etc/default/grub\nCaller: /mounts/mp_0001/usr/share/YaST2/lib/yast2/target_file.rb:34:in `read'
[Build 20180221] Internal error triggered on offline upgrades when selecting ...
Status: RESOLVED DUPLICATE of bug 1070233
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Upgrade Problems
Current
Other Other
: P5 - None : Major (vote)
: ---
Assigned To: E-mail List
Jiri Srain
https://openqa.opensuse.org/tests/616...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-22 07:59 UTC by Oliver Kurz
Modified: 2018-02-22 08:07 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: Yes
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Kurz 2018-02-22 07:59:49 UTC
## Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-update_Leap_42.1_kde@64bit fails in
[disable_grub_timeout](https://openqa.opensuse.org/tests/616431/modules/disable_grub_timeout/steps/14)
as well as in all other offline upgrades after we enabled the "disable_grub_timeout" openQA test module which is trying to open the "booting" section on upgrade.


## Reproducible

Fails since we enabled that module and triggered in all offline upgrades. The bug was already in much longer (or always).


## Expected result

Last good: [20180219](https://openqa.opensuse.org/tests/614260) (or more recent)


## Further details

Always latest result in this scenario: [latest](https://openqa.opensuse.org/tests/latest?flavor=DVD&test=update_Leap_42.1_kde&machine=64bit&distri=opensuse&arch=x86_64&version=Tumbleweed)


From y2logs:

```
No such file or directory @ rb_sysopen - /etc/default/grub
Caller:  /mounts/mp_0001/usr/share/YaST2/lib/yast2/target_file.rb:34:in `read'
```
Comment 1 Oliver Kurz 2018-02-22 08:07:12 UTC
There is already a SLE15 bug about this

*** This bug has been marked as a duplicate of bug 1070233 ***