Bug 1081856 - virtualbox-vnc should require libvncserver
virtualbox-vnc should require libvncserver
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Virtualization:Other
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Larry Finger
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-20 18:46 UTC by Michal Nowak
Modified: 2018-03-29 16:17 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michal Nowak 2018-02-20 18:46:06 UTC
VirtualBox fails to start VM configured with VNC extension pack if libvncserver is not installed:

VBoxManage: error: Could not find the VirtualBox Remote Desktop Extension library
VBoxManage: error: Details: code NS_ERROR_FAILURE (0x80004005), component ConsoleWrap, interface IConsole

Installing libvncserver0 RPM package make the problem go away and VM starts just fine.
Comment 1 Larry Finger 2018-02-21 17:54:03 UTC
The fix is now building in Factory and will be sent on to TW and Leap 15.0. I will make the same change foe Leap 42.3.
Comment 2 Swamp Workflow Management 2018-02-21 21:40:12 UTC
This is an autogenerated message for OBS integration:
This bug (1081856) was mentioned in
https://build.opensuse.org/request/show/578824 Factory / virtualbox
https://build.opensuse.org/request/show/578825 42.3 / virtualbox
Comment 3 Andreas Stieger 2018-02-25 18:56:42 UTC
Since this seems to be a non-default configuration and there is a documented work-around, I am tending towards collecting more fixes for the next maintenance update for Leap 42.3.
Comment 4 Swamp Workflow Management 2018-03-29 16:17:02 UTC
openSUSE-RU-2018:0849-1: An update that has two recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1081360,1081856
CVE References: 
Sources used:
openSUSE Leap 42.3 (src):    virtualbox-5.1.34-47.1