Bug 1081471 - sudo 1.8.22-1.1 Password Prompt Does Not Expand Username
sudo 1.8.22-1.1 Password Prompt Does Not Expand Username
Status: RESOLVED DUPLICATE of bug 1081470
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Basesystem
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-18 16:53 UTC by Ron Lovell
Modified: 2018-02-21 13:34 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ron Lovell 2018-02-18 16:53:54 UTC
The password prompt from the sudo command installed by sudo-1.8.22-1.1.x86_64 does not properly show the username for which the password is required.  Example:

lovells@ron5tum:~$ sudo -i
[sudo] password for %{p}:

Normally "%{p}" would be "lovells".  (I commented-out "Defaults targetpw"
in /etc/sudoers, so sudo(8) wants my password, not root's.)

The command otherwise works correctly, i.e. I do switch to root after entering my password.
Comment 1 Kriton Kyrimis 2018-02-18 17:53:53 UTC
Looking at the binary, I see that it contains the parameters given to configure. One of them is "--with-passprompt=[sudo] password for %{p}:", which should be "--with-passprompt=[sudo] password for %p:"

To verify this, I patched /usr/lib/sudoers.so by erasing the curly braces and adding two nulls after the colon, and now the user name is expanded correctly.
Comment 2 Antoine Belvire 2018-02-18 19:20:41 UTC
duplicate of 1081470

*** This bug has been marked as a duplicate of bug 1081470 ***
Comment 3 Ron Lovell 2018-02-21 13:34:02 UTC
Confirming fixed in sudo 1.8.22-2.1 in TW Snapshot 20180219. Great work, guys!