Bug 1081470 - Sudo's Password Prompt Contains String Instead of Root
Sudo's Password Prompt Contains String Instead of Root
Status: RESOLVED FIXED
: 1081471 1081476 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Basesystem
Current
x86-64 Other
: P5 - None : Normal with 1 vote (vote)
: ---
Assigned To: Kristyna Streitova
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-18 16:45 UTC by Frank Krüger
Modified: 2019-06-07 12:35 UTC (History)
8 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Frank Krüger 2018-02-18 16:45:32 UTC
After the update to sudo 1.8.22 (Tumbleweed 20180216) "sudo" gives the password prompt "[sudo] password for %{p}:", instead of "[sudo] password for root:".
Comment 1 Alexandre Singh 2018-02-18 17:32:12 UTC
Confirmed by me an several users in factory mailing-list.

Sudo still work as intended btw.
Comment 2 Frank Krüger 2018-02-18 18:04:55 UTC
See also https://bugzilla.opensuse.org/show_bug.cgi?id=1081471#c1.
Comment 3 Antoine Belvire 2018-02-18 18:10:30 UTC
https://build.opensuse.org/request/show/577850
Comment 4 Antoine Belvire 2018-02-18 19:20:42 UTC
*** Bug 1081471 has been marked as a duplicate of this bug. ***
Comment 5 Frank Krüger 2018-02-18 19:25:45 UTC
*** Bug 1081476 has been marked as a duplicate of this bug. ***
Comment 6 Mircea Kitsune 2018-02-18 20:17:25 UTC
Confirming the problem. As of today's Tumbleweed snapshot, I too see the password prompt string as "[sudo] password for %{p}:"
Comment 7 Kristyna Streitova 2018-02-19 11:00:57 UTC
Thank you for the report. The fix (sr#578010) is on its way to openSUSE:Factory. 

I'm closing this bug as fixed.
Comment 8 Swamp Workflow Management 2018-02-19 11:40:15 UTC
This is an autogenerated message for OBS integration:
This bug (1081470) was mentioned in
https://build.opensuse.org/request/show/578010 Factory / sudo