Bug 1081328 - [Build 20180214] GRUB2 Bootloader / kiwi: no spaces allowed in display name
[Build 20180214] GRUB2 Bootloader / kiwi: no spaces allowed in display name
Status: RESOLVED INVALID
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Live Medium
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Marcus Schaefer
E-mail List
https://openqa.opensuse.org/tests/610...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-16 11:19 UTC by Dominique Leuenberger
Modified: 2018-02-16 16:46 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dominique Leuenberger 2018-02-16 11:19:06 UTC
## Observation

openQA test in scenario opensuse-Tumbleweed-KDE-Live-x86_64-kde-live@uefi-usb fails in
[bootloader_uefi](https://openqa.opensuse.org/tests/610688/modules/bootloader_uefi/steps/3)

The kiwi file does not allow for 'spaces' in the display name, which in turn forces distro maintainers to use variants like dash or underscore; they might be technically ok, but from anoptical PoV, they are too technical to be shown on screen in the bootloader.

I'd want a way to have 'spaces' in the title.

When booting the same ISO in an non-uefi setup, and syslinux handle the boot, the title does look 'as expected'
Comment 1 Dominique Leuenberger 2018-02-16 11:20:10 UTC
For comparision, the same ISO booted on a non-uefi enabled KVM looks like this:

https://openqa.opensuse.org/tests/610683#step/bootloader/2
Comment 2 Marcus Schaefer 2018-02-16 15:22:56 UTC
I have tested a live iso build with the following setup:

<image schemaversion="6.8" name="LimeJeOS-Leap-42.3" displayname="Foo Bar">

and booted the image via kvm as follows:

* qemu-kvm -cdrom /tmp/mytest/LimeJeOS-Leap-42.3.x86_64-1.42.3.iso
* qemu-kvm -bios /usr/share/qemu/ovmf-x86_64.bin -hda /tmp/mytest/LimeJeOS-Leap-42.3.x86_64-1.42.3.iso -vga cirrus

In any case the displayed menu entry was "Foo Bar" with the space

Sorry I can't reproduce this
Comment 3 Marcus Schaefer 2018-02-16 15:25:18 UTC
In case of grub booting the confg file contained

menuentry "Failsafe -- Foo Bar" --class os --unrestricted {
    set gfxpayload=keep
    echo Loading kernel...
    ...

in case of isolinux the config file contained

label Foo Bar
    kernel linux
    ...

Can't find any error
Comment 4 Dominique Leuenberger 2018-02-16 15:37:44 UTC
Thanks for your input Marcus,

I'm pretty sure the kiwi file was changed to contain displayname="..." without spaces at one point, as kiwi did complain. Seems this is no longer the case and we simply missed to validate if this is actually still true.

I changed the kiwi file for oS:F and will retest
Comment 5 Marcus Schaefer 2018-02-16 15:39:04 UTC
Could you provide the XML parts and the bootloader config files from your build ?
Comment 6 Dominique Leuenberger 2018-02-16 16:46:46 UTC
https://build.opensuse.org/package/view_file/openSUSE:Factory:Live/livecd-openSUSE/livecd.kiwi.in?expand=1

Is the base kiwi file.

But this bug was filed way too late it seems: I recall this DID decline spaces at one point and we switched to underscore. But today, I switched back to spaces and the build was just fine.

Closing as INVALID (openQA will get the image in a couple hours, but I don't expect new issues showing up due to _->space there.