Bug 1081281 - VirtualBox video capture is buggy in version 5.2.6
VirtualBox video capture is buggy in version 5.2.6
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Virtualization:Other
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Larry Finger
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-16 05:55 UTC by Larry Finger
Modified: 2018-03-18 19:07 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Larry Finger 2018-02-16 05:55:27 UTC
When VirtualBox 5.2.4 is used to capture a video of a VM, the resulting file is corrupt. According to https://www.virtualbox.org/ticket/17307, the cause is that the variable used to record the time code is only 16 bits.

A patch changing this value to 32 bits has been prepared, and the changed code pushed to Factory. From there, it will be available to update TW and Leap 15.0. I do not believe that VB 5.1.32, which is used for Leap 42.3, is affected.
Comment 1 Larry Finger 2018-02-16 16:58:57 UTC
Fix building in Factory as request id 577311.
Comment 2 Swamp Workflow Management 2018-02-16 17:40:08 UTC
This is an autogenerated message for OBS integration:
This bug (1081281) was mentioned in
https://build.opensuse.org/request/show/577311 Factory / virtualbox
Comment 3 Swamp Workflow Management 2018-02-16 19:40:07 UTC
This is an autogenerated message for OBS integration:
This bug (1081281) was mentioned in
https://build.opensuse.org/request/show/577317 Factory / virtualbox
Comment 4 Larry Finger 2018-03-18 19:07:43 UTC
This should be fixed in 5.2.8.