Bug 1081193 - openvpn: always to asks for a password (--askpass) and fails
openvpn: always to asks for a password (--askpass) and fails
Status: RESOLVED DUPLICATE of bug 985798
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Network
Current
x86-64 openSUSE Factory
: P5 - None : Major (vote)
: ---
Assigned To: Reinhard Max
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-15 15:30 UTC by James Bottomley
Modified: 2018-02-16 23:44 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description James Bottomley 2018-02-15 15:30:30 UTC
Update 131 adds a --askpass to the systemd exec file:

https://build.opensuse.org/package/rdiff/network:vpn/openvpn?linkrev=base&rev=131

This causes openvpn always to ask for a password, which I don't need since my private keys aren't password protected (they're TPM protected instead).  For some reason systemd isn't relaying the password request so the vpn service simply fails.  Starting it manually shows the spurious password request on the console.

The -askpass option may be more secure but it breaks the setup if you don't have a password by always asking for one.  The fix for me is simple: remove the --askpass option and my system will then boot up normally.
Comment 1 Reinhard Max 2018-02-16 23:44:01 UTC
duplicate

*** This bug has been marked as a duplicate of bug 985798 ***