Bug 1081150 - FTBFS: perl-DBIx-Class-InflateColumn-FS falis to build
FTBFS: perl-DBIx-Class-InflateColumn-FS falis to build
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Daniel Lovasko
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-15 10:45 UTC by Dominique Leuenberger
Modified: 2018-03-19 14:12 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dominique Leuenberger 2018-02-15 10:45:24 UTC
The package openSUSE:Factory/perl-DBIx-Class-InflateColumn-FS has never been built against Perl 5.26 yet.

Until recently, it was simply 'unresolvable' as some of its deps still failed too; now the deps have cleared, and the package fails on its own.

From the log:

[   37s] + cd DBIx-Class-InflateColumn-FS-0.01007
[   37s] + /usr/bin/perl Makefile.PL INSTALLDIRS=vendor
[   37s] Can't locate inc/Module/Install.pm in @INC (you may need to install the inc::Module::Install module) (@INC contains: /usr/lib/perl5/site_perl/5.26.1/x86_64-linux-thread-multi /usr/lib/perl5/site_perl/5.26.1 /usr/lib/perl5/vendor_perl/5.26.1/x86_64-linux-thread-multi /usr/lib/perl5/vendor_perl/5.26.1 /usr/lib/perl5/5.26.1/x86_64-linux-thread-multi /usr/lib/perl5/5.26.1 /usr/lib/perl5/site_perl) at Makefile.PL line 1.
[   37s] BEGIN failed--compilation aborted at Makefile.PL line 1.
[   37s] error: Bad exit status from /var/tmp/rpm-tmp.wWNCHB (%build)
Comment 1 Dominique Leuenberger 2018-03-19 14:12:59 UTC
r2 | dimstar_suse | 2018-03-04 11:50:20 | 4370f6b6e6a0794828338c2c198b182c | 0.01007 | rq581533

- fix build on newer systems, add explicit Module::Install requirement