Bug 1081055 - ACPI problem on MSI GS40 6QE Phantom laptop
ACPI problem on MSI GS40 6QE Phantom laptop
Status: RESOLVED FEATURE
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Basesystem
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-14 20:55 UTC by Ivan Levshin
Modified: 2018-03-02 16:13 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
hwinfo output (1.41 MB, text/plain)
2018-03-02 15:35 UTC, Ivan Levshin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ivan Levshin 2018-02-14 20:55:20 UTC
Hi,

I'm in trouble with some things on my MSI GS40 running Tumbleweed:
- Bluetooth doesn't work at all
- if I have external monitor connected via HDMI, powersaving doesn't work (it looks like that: first laptop monitor switching off, then, after some time, external monitor switching off. But after some time it switching on again)
- if I plug my Headphones into the "Headphone" socket, there is no automatic change from Speakers to Headphones
- if there was a powersaving attempt, I see that soundcard changed! Sometimes that's Analogue Audio, sometimes that's Monitor HDMI Audio
- again after powersaving attempt was done or in the case when I finished DE session and started it again, WiFi isn't working, I have to swtich it off and on again to make it working.

I'm using KDE and tried many variants of Power Management: no luck
Same problem exists in other DE: GNOME, XFCE, Cinnamon so it doesn't looks like DE-dependent

I suppose all mentioned problem relates to ACPI, during boot there are some error messages:

ACPI Error: [\_SB_.PCI0.XHC_.RHUB.HS11] Namespace lookup failure, AE_NOT_FOUND (20170831/dswload-210)
ACPI Exception: AE_NOT_FOUND, During name lookup/catalog (20170831/psobject-252)
ACPI Exception: AE_NOT_FOUND, (SSDT:xh_rvp11) while loading table (20170831/tbxfload-228)
ACPI Error: 1 table load failures, 8 successful (20170831/tbxfload-246)
ACPI Error: [^^^PEG0.PEGP.EASP] Namespace lookup failure, AE_NOT_FOUND (20170831/psargs-364)
ACPI Error: Method parse/execution failed \_SB.PCI0.LPCB.EC._REG, AE_NOT_FOUND (20170831/psparse-550)

Also there are 2 string where Bluetooth mentioned and they are about errors again, I'm sure they are here but I can't find it in dmesg output.

These problem were here always since I bought GS40 and installed TW on it.

Before GS40 I had GE62 6QC with Tumbleweed running and I'd like to say there were no such problem at all! Both GS40 and GE62 share the same Intel HM170 platform and very similar from perspective of hardware. So I suppose all problems seems to be related with ACPI or, probably, the BIOS code problem.

Please help me to fix that, I'll provide any additional info in case if it's needed.
Comment 1 Takashi Iwai 2018-03-02 14:14:39 UTC
All are different issues but they are irrelevant with each other.  So please report each issue one by one.

Also, update the detailed hardware information (e.g. the output of hwinfo) at least in one bug report.  If you have another machine that is similar but working, get the hardware information from that too as a reference.  Thanks.
Comment 2 Ivan Levshin 2018-03-02 15:35:05 UTC
Takeshi,

Of course I understand these issues might be irrelevant - and now I see that BT issue at least irrelevant as it is solved already.

Also I'd like to say that unfortunately I', not a Linux expert so just mentioned all problem I see here. I'm not sure if ACPI problem impacts my system at all or this is something like a cosmetic problem, but at least I can say that in my understanding ACPI might be related with power management. Can we work under ACPI problem in this bugreport? Let's forgot about sound problem, I'll raise another request for it if needed.

Abd I'm sorry for my forgetfulness about HW details

mynote:/home/ivan # uname -a
Linux mynote.levshin.site 4.15.7-1.g7088472-default #1 SMP PREEMPT Fri Mar 2 11:06:09 UTC 2018 (7088472) x86_64 x86_64 x86_64 GNU/Linux

This is the kernel you provided for bug#1082504

mynote:/home/ivan # cat /etc/os-release 
NAME="openSUSE Tumbleweed"
# VERSION="20180227"
ID=opensuse
ID_LIKE="suse"
VERSION_ID="20180227"
PRETTY_NAME="openSUSE Tumbleweed"
ANSI_COLOR="0;32"
CPE_NAME="cpe:/o:opensuse:tumbleweed:20180227"
BUG_REPORT_URL="https://bugs.opensuse.org"
HOME_URL="https://www.opensuse.org/"

I'll attach hwinfo output as well
Comment 3 Ivan Levshin 2018-03-02 15:35:30 UTC
Created attachment 762514 [details]
hwinfo output
Comment 4 Takashi Iwai 2018-03-02 15:43:02 UTC
I'm not sure whether any of the issues you mentioned come from ACPI.
There are some bugs in BIOS and provide invalid ACPI table, which resulted in the error messages.  But, AFAIK, most of power-saving issues are not about ACPI but about drivers.

The power on/off is a different story, though; e.g. if the machine gets turned on spuriously, it's likely something to do with ACPI.  But some breakage after PM or runtime PM is mostly a bug in the driver.
Comment 5 Ivan Levshin 2018-03-02 16:10:06 UTC
OK, Takeshi

In this case this report might be closed. Thanks for explanations.
Comment 6 Takashi Iwai 2018-03-02 16:13:02 UTC
OK, but as already mentioned, please open each issue in a separate report.
This will make the things easier to track.  If they are really ACPI issues, they can be dup'ed to this and reopend.