Bug 1081018 - YaST2 errors while installing Tumbleweed (inst_proposal failed, undefined methods and grub problems)
YaST2 errors while installing Tumbleweed (inst_proposal failed, undefined met...
Status: VERIFIED FIXED
: 1081208 1081597 1081995 1082094 1083580 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: YaST2
Current
64bit Other
: P5 - None : Normal (vote)
: ---
Assigned To: YaST Team
Jiri Srain
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-14 15:12 UTC by Renata Carvalho
Modified: 2018-03-09 15:19 UTC (History)
13 users (show)

See Also:
Found By: Community User
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
I copied all from /var/log/YaST2 and ran the command save_y2logs which generated a zip (234.02 KB, application/zip)
2018-02-14 15:12 UTC, Renata Carvalho
Details
Here are some pictures showing the error messages. (460.75 KB, image/jpeg)
2018-02-14 15:20 UTC, Renata Carvalho
Details
Screenshot of the internal error (20.84 KB, image/jpeg)
2018-02-22 16:11 UTC, LTC BugProxy
Details
yast2 logs - when no swap partition is created and the error occured (87.08 KB, application/x-xz)
2018-02-22 16:11 UTC, LTC BugProxy
Details
yast2 logs - when a swap partition had been created and all went fine (203.84 KB, application/x-xz)
2018-02-22 16:11 UTC, LTC BugProxy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Renata Carvalho 2018-02-14 15:12:58 UTC
Created attachment 760160 [details]
I copied all from /var/log/YaST2 and ran the command save_y2logs which generated a zip

I tried several times to install Tumbleweed in my notebook.
Everytime I got several errors and when I finally got to complete the installation there was another error about "no kernel found" in 99%.
It rebooted my system and there was no Tumbleweed installed at all.

I got the logs and some photos of the error messages, I am gonna attach them here.

To generate the error, I just downloaded Tumbleweed from OpenSUSE's website and got it to a USB stick with dd. I booted it and installed with the configs for Brazil (time and keyboard), default partitions the installer suggested me and I got the error both with network on and off.

1. Clicked in Custom Desktop Environment
2. Chose Gnome
3. Filled information about new user
4. Clicked next

There was this error.
Comment 1 Renata Carvalho 2018-02-14 15:20:23 UTC
Created attachment 760163 [details]
Here are some pictures showing the error messages.

I also ran the "check installation media" and got the message in the red square in one of the pictures.
Comment 2 Stefan Schubert 2018-02-15 11:38:09 UTC
Josef, could you please have short look here ? Thanks !

2018-02-14 11:45:45 <1> install(3892) [Ruby] bootloader/udev_mapping.rb:67 /dev/mint-vg/swap_1 looked as kernel device name: /dev/mint-vg/swap_1
2018-02-14 11:45:45 <2> install(3892) [Ruby] yast/builtins.rb:586 tostring builtin called on wrong type Class
2018-02-14 11:45:45 <3> install(3892) [Ruby] yast/wfm.rb:253 Client /mounts/mp_0001/usr/share/YaST2/clients/bootloader_proposal.rb failed with 'undefined method `to_sym' for nil:NilClass' (NoMethodError).
Backtrace:
/mounts/mp_0001/usr/share/YaST2/lib/bootloader/udev_mapping.rb:125:in `mount_by_udev'
/mounts/mp_0001/usr/share/YaST2/lib/bootloader/udev_mapping.rb:113:in `udev_name_for'
/mounts/mp_0001/usr/share/YaST2/lib/bootloader/udev_mapping.rb:104:in `kernel_to_udev'
/mounts/mp_0001/usr/share/YaST2/lib/bootloader/udev_mapping.rb:69:in `to_mountby_device'
/mounts/mp_0001/usr/share/YaST2/lib/bootloader/grub2base.rb:295:in `propose_resume'
Comment 3 Josef Reidinger 2018-02-15 12:39:39 UTC
Stefan - problem is that mount_by returns nil that is something bootloader unexpect.

Ancor - how to behave if mount_by is set to nil? I expect storage-ng itself use some default value like in past, not?

code that failed: https://github.com/yast/yast-bootloader/blob/master/src/lib/bootloader/udev_mapping.rb#L125
Comment 4 Ancor Gonzalez Sosa 2018-02-15 12:49:27 UTC
I would say the y2-booloader expectation (having some not nil value in mount_by) is reasonable. So I guess this should be fixed in the storage-ng side.
Comment 5 Ancor Gonzalez Sosa 2018-02-15 12:55:29 UTC
I added this bug to the existing card (to be addressed shortly) about improving the mount_by settings.
Comment 6 Ancor Gonzalez Sosa 2018-02-15 13:02:54 UTC
After an extra check, we detected that is nil because the partition is not mounted. In that case, returning nil is correct. So forget what I said. The error is in the y2bootloader side, not in storage-ng.

Removed from the mentioned card.
Comment 7 Josef Reidinger 2018-02-15 14:43:05 UTC
fixed by https://github.com/yast/yast-bootloader/pull/485
Comment 8 Josef Reidinger 2018-02-19 08:50:49 UTC
*** Bug 1081208 has been marked as a duplicate of this bug. ***
Comment 9 Ancor Gonzalez Sosa 2018-02-22 15:19:23 UTC
*** Bug 1081597 has been marked as a duplicate of this bug. ***
Comment 10 Ancor Gonzalez Sosa 2018-02-22 15:30:09 UTC
*** Bug 1082094 has been marked as a duplicate of this bug. ***
Comment 11 Ancor Gonzalez Sosa 2018-02-22 15:42:14 UTC
*** Bug 1081995 has been marked as a duplicate of this bug. ***
Comment 12 LTC BugProxy 2018-02-22 16:11:21 UTC
When installing on a multipathed LUN, attached via two NPIV-enabled zfcp adaptors, I ran into a yast error when specified the following manual partitioning scheme:

1st partition: 500MiB ext3 as /boot/zipl
2nd partition: 15GiB ext4 as /root
no swap

When reaching the overview with the "Installation settings", I ran into an internal error, see attached screenshot.
I also collected y2logs.
When doing the same but adding a third partition with swap, this problem does not occur.

Question: In the past, when no swap was defined, an informational warning message appeared that there is no swap volume. This warning message does not occur, when doing the same thing on DASD.

If I create the following partitions:
1st partition: 500MiB ext3 as /boot/zipl
2nd partition: 15GiB ext4 as /root
3rd partition: remainder as swap
the system can be installed as expected.
This is a fix of bug#1081018 that is already fixed. The fix will be available in the next Beta/RC

*** This bug has been marked as a duplicate of bug 1081018 ***
Comment 13 LTC BugProxy 2018-02-22 16:11:24 UTC
Created attachment 761288 [details]
Screenshot of the internal error
Comment 14 LTC BugProxy 2018-02-22 16:11:26 UTC
Created attachment 761289 [details]
yast2 logs - when no swap partition is created and the error occured
Comment 15 LTC BugProxy 2018-02-22 16:11:27 UTC
Created attachment 761290 [details]
yast2 logs - when a swap partition had been created and all went fine
Comment 16 Josef Reidinger 2018-02-22 16:40:57 UTC
(In reply to LTC BugProxy from comment #13)
> Created attachment 761288 [details]
> Screenshot of the internal error

Hello IBM,
this internal error will be fixed in next release and is not related to swap, but more to fact that there is a partition without mount_by option ( so usually partition that is not mounted which is solved by mounting it as swap ).
Comment 17 Randy Wright 2018-02-22 17:24:24 UTC
I filed one of the bugs dup'ed to this one.  Since this issue is affecting several of my colleagues at HPE and preventing progress with the newly-received Beta7, can you tell us a bit more about how this can be prevented?  

I am concerted I see the comment 16 statement that "there is a partition without mount_by option ( so usually partition that is not mounted which is solved by mounting it as swap )."
Comment 18 Randy Wright 2018-02-22 17:40:45 UTC
I intended to mention in comment 17 the fact that our test systems usually have multiple disks, often other disks contain other releases (SLES11, SLES12) that I don't want to mix with the SLES15 beta.   Is the remark "there is a partition without mount_by option" meaning I need to mount all visible partitions from all disks to the SLES15 instance?   

Please clarify what might be done - or not done - to avoid this issue since the failure to install is blocking our ability to generally test beta 7.
Comment 19 Lukas Ocilka 2018-02-23 08:19:11 UTC
Josef, PLS try to answer questions in comments #17 and #18. Thx!
Comment 20 Josef Reidinger 2018-02-23 08:39:31 UTC
(In reply to Randy Wright from comment #18)
> I intended to mention in comment 17 the fact that our test systems usually
> have multiple disks, often other disks contain other releases (SLES11,
> SLES12) that I don't want to mix with the SLES15 beta.   Is the remark
> "there is a partition without mount_by option" meaning I need to mount all
> visible partitions from all disks to the SLES15 instance?

It is one possible workaround
   
> 
> Please clarify what might be done - or not done - to avoid this issue since
> the failure to install is blocking our ability to generally test beta 7.

Another possible workaround is to use driver update to have new rpm in installation system. I can prepare such rpm or if you have access to SLE15 build service then you can find it yourself. Or you can also take rpm from opensuse as for bootloader it is identical packages ( for now in this phase of development ) at https://build.opensuse.org/package/show/openSUSE:Leap:15.0/yast2-bootloader
target standard.

If you have any questions, do not hesitate to ask.
Comment 21 Randy Wright 2018-02-23 21:54:39 UTC
I was successful installing Beta7 when I chose to allow the new SLES15 instance to mount the swap partition from each of the other disks in the SUT.  As I recall, prior versions of SLES would have done this by default.   Since I didn't need to present any other non-swap filesystems from the installs on the other disks, this will be an adequate workaround to enable testing Beta7.
Comment 22 LTC BugProxy 2018-03-08 14:31:34 UTC
------- Comment From ROESCH3@de.ibm.com 2018-03-08 09:26 EDT-------
Tested with SLES 15 RC1. This problem is fixed
Comment 23 Lukas Ocilka 2018-03-08 14:37:06 UTC
Thanks for validation! :)
Comment 24 Josef Reidinger 2018-03-09 15:19:27 UTC
*** Bug 1083580 has been marked as a duplicate of this bug. ***