Bug 1080954 - Accessibility: Tab-order inside the graphical installer is mixed
Accessibility: Tab-order inside the graphical installer is mixed
Status: RESOLVED WONTFIX
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Installation
Current
Other Other
: P5 - None : Minor (vote)
: ---
Assigned To: YaST Team
Jiri Srain
https://trello.com/c/Pz7s7LHR/2120-fi...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-14 09:54 UTC by Nick Singer
Modified: 2022-09-21 14:26 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nick Singer 2018-02-14 09:54:41 UTC
Scenario:

One wants to install openSUSE Tumbleweed only by using his keyboard. For navigation inside the graphical installer he uses "Tab" to navigate the button-focus one forward and "Shift+Tab" to navigate the focus backwards.


Problem:

Most screens start out with the focus on the "Next" button. Using "Tab" allows the user to reach each and every button inside the installer (e.g. the language selection). Using "Shift+Tab" on the other hand only cycles the main control-buttons ("Help", "Abort", "Next") and the user is unable to ever reach other buttons on the screen.


Expected behavior:

"Shift+Tab" should be able to reach the same buttons as just "Tab" is able to reach. 


How to reproduce:

Just start the graphical YaST installer from TW and hold down "Tab" for a couple of seconds. Observe how all buttons start flashing (because they get the focus). Do the same thing but with "Shift+Tab" and observe how only the buttons on the lower edge of the screen start flashing.
Comment 1 Stefan Hundhammer 2018-02-22 12:38:30 UTC
Qt5 docs about this:

  http://doc.qt.io/qt-5/focus.html

Yes, you are right, [Shift-Tab] should cycle through the widgets in the reverse order that [Tab] does. But I am not sure how much influence we have on that from the UI side; this should be done automatically by Qt. If the forward tab order works, the reverse order should work as well.

We'll need to investigate this more deeply once we have some breathing space (which now we clearly don't).
Comment 2 Nick Singer 2018-02-22 12:42:36 UTC
Thanks for the explanation. Sure thing, not that important after all. Just noticed it and wanted to write it down.
Comment 3 Stefan Hundhammer 2018-02-22 14:01:12 UTC
Added Trello task for including into a future sprint:

https://trello.com/c/Pz7s7LHR/2120-fix-qt-ui-reverse-tab-order
Comment 4 Stefan Hundhammer 2022-09-21 14:26:36 UTC
This is now 4 years old, and we didn't find time to address this, and nobody seems to have a good idea anyway. It's unrealistic that this will happen in the forseeable future.

Closing.