Bug 1080787 - Latest nvidia rpm breaks SDDM
Latest nvidia rpm breaks SDDM
Status: RESOLVED DUPLICATE of bug 1080742
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: X11 3rd Party Driver
Leap 42.3
x86-64 openSUSE 42.3
: P5 - None : Critical (vote)
: ---
Assigned To: E-mail List
Stefan Dirsch
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-13 11:39 UTC by Mathias Homann
Modified: 2018-02-13 16:29 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
nvidia bugreport log with the driver installed from rpm from nvidia repo (96.81 KB, application/gzip)
2018-02-13 13:07 UTC, Mathias Homann
Details
nvidia bugreport log with the driver installed using the official blob installer from nvidia.com (89.89 KB, application/gzip)
2018-02-13 13:08 UTC, Mathias Homann
Details
nvidia-bug-report.log.gz from RPM install (111.64 KB, application/gzip)
2018-02-13 15:17 UTC, Fred Jones
Details
nvidia bugreport, install from rpm (but see comments) (129.73 KB, application/gzip)
2018-02-13 15:19 UTC, Peter Sütterlin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mathias Homann 2018-02-13 11:39:09 UTC
After installing the latest nvidia driver rpm through zypper sddm does not start properly anymore, all I get is a black screen, a mouse pointer, and lots of error messages in the system journal:

Feb 13 12:16:08 kumiko kernel: NVRM: Xid (PCI:0000:01:00): 13, Graphics Exception on GPC 0: 2D KIND Violation. Coordinates: (0x8, 0x0)
Feb 13 12:16:08 kumiko kernel: NVRM: Xid (PCI:0000:01:00): 13, Graphics Exception: ESR 0x500420=0x80000040 0x500434=0x8 0x500438=0x2a 0x50043c=0x10017
Feb 13 12:16:08 kumiko kernel: NVRM: Xid (PCI:0000:01:00): 13, Graphics Exception on GPC 1: 2D KIND Violation. Coordinates: (0x0, 0x0)
Feb 13 12:16:08 kumiko kernel: NVRM: Xid (PCI:0000:01:00): 13, Graphics Exception: ESR 0x508420=0x80000040 0x508434=0x0 0x508438=0x2a 0x50843c=0x10017
Feb 13 12:16:08 kumiko kernel: NVRM: Xid (PCI:0000:01:00): 13, Graphics Exception: ChID 0013, Class 0000902d, Offset 0000010c, Data 00000001
Feb 13 12:16:08 kumiko kernel: NVRM: Xid (PCI:0000:01:00): 31, Ch 00000013, engmask 00000101, intr 50000000


After removing the driver rpms and installing the same driver version by means of the official nvidia installer all works fine.
Comment 1 Stefan Dirsch 2018-02-13 12:25:44 UTC
Hmm. Could you provide results of running nvidia-bug-report.sh? Preferrably when RPMs are installed and when you install the driver manually.
Comment 2 Mathias Homann 2018-02-13 13:07:50 UTC
Created attachment 759979 [details]
nvidia bugreport log with the driver installed from rpm from nvidia repo
Comment 3 Mathias Homann 2018-02-13 13:08:32 UTC
Created attachment 759980 [details]
nvidia bugreport log with the driver installed using the official blob installer from nvidia.com
Comment 4 Stefan Dirsch 2018-02-13 13:33:44 UTC
Hmm. Nothing obvious I could find. Could it be that both resulting logs are for doing the manual installation? I could see this in the logfile:

-> Installing both new and classic TLS OpenGL libraries.
-> Installing both new and classic TLS 32bit OpenGL libraries.
-> Install NVIDIA's 32-bit compatibility libraries? (Answer: Yes)
-> Will install GLVND GLX client libraries.
-> Will install GLVND EGL client libraries.
-> Skipping GLX non-GLVND file: "libGL.so.390.25"
-> Skipping GLX non-GLVND file: "libGL.so.1"
-> Skipping GLX non-GLVND file: "libGL.so"
-> Skipping EGL non-GLVND file: "libEGL.so.390.25"
-> Skipping EGL non-GLVND file: "libEGL.so"
-> Skipping EGL non-GLVND file: "libEGL.so.1"
-> Skipping GLX non-GLVND file: "./32/libGL.so.390.25"
-> Skipping GLX non-GLVND file: "libGL.so.1"
-> Skipping GLX non-GLVND file: "libGL.so"
-> Skipping EGL non-GLVND file: "./32/libEGL.so.390.25"
-> Skipping EGL non-GLVND file: "libEGL.so"
-> Skipping EGL non-GLVND file: "libEGL.so.1"
[...]
Comment 5 Fred Jones 2018-02-13 15:17:59 UTC
Created attachment 759991 [details]
nvidia-bug-report.log.gz from RPM install

As title - Nvidia bug report run on my Opensuse 42.3 after install using YAST and the RPM.
Comment 6 Peter Sütterlin 2018-02-13 15:19:21 UTC
Created attachment 759992 [details]
nvidia bugreport, install from rpm (but see comments)

Having the same issue (TW update 0208->0210).

Blind login is possible, but my plasma session doesn't come up properly either.

Unfortunately didn't spot the nvidia packages in the list and thought it was the new kernel (4.15.1->4.15.2), and tried to reinstall the nvidia modules.
Didn't fix things, rebooted 4.15.1 (but now nvidia modules complained, as they had obviously been compiled against 4.15.2, the then-running kernel?)

I ended up removing all nvidia stuff, and reinstalling it. However, the compile seemed to also have used the 4.15.2 headers (does it use /usr/src/linux?) they wouldn't load. I did a manual recompile (only) of the kernel modules using dkms.

log is from that state now.

If too complicated -> discard :)
Comment 7 Peter Sütterlin 2018-02-13 16:12:13 UTC
Some more observations:
If I log in blind, then disable compositor, and restart some applications, I can 'use' the desktop.

/var/log/Xorg.0.log gets flooded with
[  6580.767] (WW) NVIDIA(0): Suspend swap group failed.
[  6580.768] (WW) NVIDIA(0): Resume swap group failed.
Comment 8 Stefan Dirsch 2018-02-13 16:29:42 UTC
Let's handle this in the previous bug.

*** This bug has been marked as a duplicate of bug 1080742 ***