Bug 1080545 - Update samba to latest upstream bugfix release
Update samba to latest upstream bugfix release
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Samba
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Samuel Cabrero
The 'Opening Windows to a Wider World' guys
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-12 09:24 UTC by Samuel Cabrero
Modified: 2018-02-19 09:52 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Samuel Cabrero 2018-02-12 09:24:33 UTC
Samba 4.7.5 is released with the following bugfixes:

Since 4.7.4:
  + smbd tries to release not leased oplock during oplock II downgrade;         
    (bso#13193);                                                                
  + Fix copying file with empty FinderInfo from Windows client to Samba share   
    with fruit; (bso#13181);                                                    
  + build: Deal with recent glibc sunrpc header removal; (bso#10976);           
  + Make Samba work with tirpc and libnsl2; (bso#13238);                        
  + vfs_ceph: Add fs_capabilities hook to avoid local statvfs; (bso#13208);     
  + Kerberos: PKINIT: Can't decode algorithm parameters in clientPublicValue;   
    (bso#12986);                                                                
  + ctdb-recovery-helper: Deregister message handler in error paths;            
    (bso#13188);                                                                
  + samba: Only use async signal-safe functions in signal handler; (bso#13240); 
  + Kerberos: PKINIT: Can't decode algorithm parameters in clientPublicValue;   
    (bso#12986);                                                                
  + repl_meta_data: Fix linked attribute corruption on databases                
    with unsorted links on expunge. dbcheck: Add functionality to fix the       
    corrupt database; (bso#13228);                                              
  + Fix smbd panic when chdir returns error during exit; (bso#13189);           
  + Make Samba work with tirpc and libnsl2; (bso#13238);                        
  + Fix POSIX ACL support on HPUX and possibly other big-endian OSs;            
    (bso#13176);                           

Since 4.7.3:
  + s3: smbclient: Implement 'volume' command over SMB2; (bso#13140);           
  + s3: libsmb: Fix valgrind read-after-free error in                           
    cli_smb2_close_fnum_recv(); (bso#13171);                                    
  + s3: libsmb: Fix reversing of oldname/newname paths when creating a          
    reparse point symlink on Windows from smbclient; (bso#13172);               
  + Build man page for vfs_zfsacl.8 with Samba; (bso#12934);                    
  + repl_meta_data: Allow delete of an object with dangling backlinks;          
    (bso#13095);                                                                
  + s4:samba: Fix default to be running samba as a deamon; (bso#13129);         
  + Performance regression in DNS server with introduction of DNS wildcard,     
    ldb: Release 1.2.3; (bso#13191);                                            
  + vfs_zfsacl: Fix compilation error; (bso#6133);                              
  + "smb encrypt" setting changes are not fully applied until full smbd         
    restart; (bso#13051);                                                       
  + winbindd: Fix idmap_rid dependency on trusted domain list; (bso#13052);     
  + vfs_fruit: Proper VFS-stackable conversion of FinderInfo; (bso#13155);      
  + winbindd: Dependency on trusted-domain list in winbindd in critical auth    
    codepath; (bso#13173);                                                      
  + repl_meta_data: Fix removing of backlink on deleted objects; (bso#13120);   
  + ctdb: sock_daemon leaks memory; (bso#13153);                                
  + TCP tickles not getting synchronised on CTDB restart; (bso#13154);          
  + winbindd: winbind parent and child share a ctdb connection; (bso#13150);    
  + pthreadpool: Fix deadlock; (bso#13170);                                     
  + pthreadpool: Fix starvation after fork; (bso#13179);                        
  + messaging: Always register the unique id; (bso#13180);                      
  + s4/smbd: set the process group; (bso#13129);                                
  + Fix broken linked attribute handling; (bso#13095);                          
  + The KDC on an RWDC doesn't send error replies in some situations;           
    (bso#13132);                                                                
  + libnet_join: Fix 'net rpc oldjoin'; (bso#13149);                            
  + g_lock conflict detection broken when processing stale entries;             
    (bso#13195);                                                                
  + s3:smb2_server: allow logoff, close, unlock, cancel and echo on expired     
    sessions; (bso#13197);                                                      
  + s3:libads: net ads keytab list fails with "Key table name malformed";       
    (bso#13166); (bsc#1067700);                                                 
  + Fix crash in pthreadpool thread after failure from pthread_create;          
    (bso#13170);                                                                
  + s4:samba: Allow samba daemon to run in foreground; (bso#13129);             
    (bsc#1065551);                                                              
  + third_party: Link the aesni-intel library with "-z noexecstack";            
    (bso#13174);                                                                
  + vfs_glusterfs: include glusterfs/api/glfs.h without relying on "-I"         
    options; (bso#13125);
Comment 1 David Disseldorp 2018-02-12 10:11:46 UTC
This list looks good to me Samuel. Thanks!
Comment 2 Samuel Cabrero 2018-02-12 19:03:47 UTC
Depends on ldb 1.2.3:
  + Performance regression in DNS server with introduction of DNS wildcard;     
    (bso#13191);
Comment 4 Samuel Cabrero 2018-02-19 09:52:20 UTC
Released.