Bug 1080493 - Display Manager sddm seems to not read proper Window Manager
Display Manager sddm seems to not read proper Window Manager
Status: RESOLVED INVALID
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: X11 Applications
Current
All openSUSE Factory
: P5 - None : Normal (vote)
: ---
Assigned To: Fabian Vogt
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-11 23:31 UTC by Tony Su
Modified: 2018-07-09 15:09 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tony Su 2018-02-11 23:31:14 UTC
Have tested with both the fvwm2 and awesome Window Managers.

No matter what is configured with

update-alternatives --config default-xsession.desktop

On next boot, the currently configured window manager persists.

Only by disabling auto-login and then selecting the window manager in the sddm login screen can you change the window manager, and then that setting persists until it's changed in the sddm login window again (no alternatives setting works, ever). 

Did not test whether the window manager appearing as an sddm login option is because of an alternatives configuration or if exists in /etc/alternatives/, the latter can exist without the former.

TW version isn't likely relevant but is seen on the current image 20180129
Comment 1 Fabian Vogt 2018-02-13 08:56:32 UTC
That's how sddm's configuration works.

sddm stores the last window manager in /var/lib/sddm/state.conf.

default-xsession is only used:

- The first time sddm is started
- As default autologin session (unless you configure a different one in the sddm configuration)
Comment 2 Fabian Vogt 2018-07-09 15:09:48 UTC
Works as intended - if do not think this is the case, please reopen.