Bug 1080489 - Installation of Tumbleweed fails with DeviceRealDisk for Storage:Module
Installation of Tumbleweed fails with DeviceRealDisk for Storage:Module
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Installation
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
Jiri Srain
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-11 19:53 UTC by Ladislav Mate
Modified: 2018-04-27 14:10 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---
ancor: needinfo? (ladislav.mate)


Attachments
Logs from installation (50.48 KB, application/x-xz)
2018-02-11 19:53 UTC, Ladislav Mate
Details
yast2-trans-en_US.rpm digest failure (14.27 KB, image/png)
2018-02-11 19:55 UTC, Ladislav Mate
Details
y2log from Leap 15.0 beta (106.28 KB, application/x-xz)
2018-02-11 20:15 UTC, Ladislav Mate
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ladislav Mate 2018-02-11 19:53:53 UTC
Created attachment 759735 [details]
Logs from installation

Hello,
I'm trying to install openSUSE-Tumbleweed-NET-x86_64-Snapshot20180209-Media.iso
in KVM guest. 

Steps which I have done: 
1. Started minimal installation (Server mode) , de-selected App armor and created /home as btrfs subvolume instead of XFS.
2. Installation hung after some time during package instllation (high CPU usage in guest and in Host), no I/O to backing Logical Volume for VM Guest
3. Restarted the VM and Started new installation  
4. Received error "DeviceRealDisk for Storage:Module" during initialization phase.
Logs attached from installation.

Plus yast2-trans-en_US.rpm digest verification failed during installation.

btw. something similar happened to me with Leap 15.0 Beta image openSUSE-Leap-15.0-NET-x86_64-Build124.1-Media.iso today on physical desktop system which contained already few other OSes on multiple disks.
Comment 1 Ladislav Mate 2018-02-11 19:55:25 UTC
Created attachment 759736 [details]
yast2-trans-en_US.rpm digest failure
Comment 2 Ladislav Mate 2018-02-11 20:15:19 UTC
Created attachment 759737 [details]
y2log from Leap 15.0 beta
Comment 3 Ancor Gonzalez Sosa 2018-03-05 09:20:43 UTC
This looks to me like a duplicate of bug#1071454. That is, update fails if /var is in a separate partition (or it's not found).

So correct me if I'm wrong: you were trying to upgrade the system to Tumbleweed, not performing a full clean reinstall. Isn't it?

Moving back to y2maintainers while I try to clarify the situation.
Comment 4 Steffen Winterfeldt 2018-04-27 14:10:42 UTC
Closing as there's been no response for 8 weeks.

Likely this has been fixed meanwhile.

If you can provide the requested information, feel free to re-open.