Bug 1080488 - Updating to libLLVM5 5.0.1-4.2 makes KDE unusable
Updating to libLLVM5 5.0.1-4.2 makes KDE unusable
Status: RESOLVED DUPLICATE of bug 1080578
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Development
Current
x86-64 Other
: P5 - None : Critical (vote)
: ---
Assigned To: Michal Srb
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-11 19:35 UTC by Luis Correia
Modified: 2018-02-12 15:12 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Luis Correia 2018-02-11 19:35:11 UTC
Yesterday after updating my Tumbleweed system, I realized I could not reboot via the the desktop (I'm on KDE). The normal logoff greeter would not appear and I would get a notification saying it had crashed. I rebooted my system by hitting ctrl-alt-F2 to get to a text console.

After the system rebooted, I could never get it to boot again, the mouse cursor would appear but instead of the logon page, it would only display a white background.

Booting from previous snapshots and installing updates for different things one by one, I managed to narrow it down to libLLVM5 5.0.1-4.2 (previous version was 5.0.1-4.1, and it worked fine). As soon as that gets updated, the desktop stops working normally and it will no longer boot again. Booting from the pre-update snapshot makes things work again.


This system is running an AMD FX-8350 CPU, 16GB of RAM and two Radeon 290X's.
Comment 1 Michal Srb 2018-02-12 15:12:40 UTC
I don't think libLLVM5 5.0.1-4.2 is the culprit here. The version 5.0.1-4.2 only differs from 5.0.1-4.1 by optimizations and fixes in the build process. Nothing changed in the final package.

Mesa uses LLVM for AMD cards and it is possible that changing LLVM invalidates the shader cache. There is a bug in Qt5 that causes bad rendering if shader caches entries are rejected. The symptom - white screen in place of sddm - also matches: bug 1080578

You can temporary solve it by deleting ~/.cache and /var/lib/sddm/.cache. However, if you upgrade or downgrade Mesa, it will come back and you have to delete the cache again. We are working on a fix and plan to release it before any update to Mesa.

If this workaround does not help, please reopen.

*** This bug has been marked as a duplicate of bug 1080578 ***