Bug 1080468 - YaST Boot loader section fails to start due to Cyrillic (Russian) regional settings
YaST Boot loader section fails to start due to Cyrillic (Russian) regional se...
Status: RESOLVED DUPLICATE of bug 1074543
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: YaST2
Current
x86-64 SUSE Other
: P5 - None : Major (vote)
: ---
Assigned To: YaST Team
Jiri Srain
https://trello.com/c/WkaOJ306
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-11 11:40 UTC by Alex Zauzolkov
Modified: 2018-02-12 12:52 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---
locilka: needinfo? (jreidinger)


Attachments
Log file from save_y2logs (5.33 MB, application/x-xz)
2018-02-11 11:40 UTC, Alex Zauzolkov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Zauzolkov 2018-02-11 11:40:12 UTC
Created attachment 759721 [details]
Log file from save_y2logs

After updating of whole distibution (Tumbleweed) I can't access "Boot loader" section of YaST. Probably (by error code), it can not process letters from the cyrrhic alphabet in the title of the boot section. I set all regional settings to English / US, but it doesn't help. During installation of openSUSE, one of the GRUB menu items was automatically named as "Windows 7 на /dev/sda1" ("на" - possible cause of the failure).
If you need any additional files for diagnosis, please write.

Software versions:
yast2-bootloader - 4.0.15-1.1
yast2 - 4.0.49-1.1

Error code:

/usr/lib/YaST2/bin/y2start:58:in `<main>'
2018-02-11 21:12:59 <3> compik(23411) [Ruby] yast/wfm.rb:276 Internal error. Please report a bug report with logs.
Run save_y2logs to get complete logs.
Details: invalid byte sequence in US-ASCII
Caller:  /usr/lib64/ruby/gems/2.5.0/gems/cfa_grub2-0.6.5/lib/cfa/grub2/grub_cfg.rb:18:in `==='
Comment 1 Michal Filka 2018-02-12 09:11:23 UTC
(In reply to Alex Zauzolkov from comment #0)
> Created attachment 759721 [details]
> Log file from save_y2logs
> 
> After updating of whole distibution (Tumbleweed) I can't access "Boot
> loader" section of YaST. Probably (by error code), it can not process
> letters from the cyrrhic alphabet in the title of the boot section. I set
> all regional settings to English / US, but it doesn't help. During
> installation of openSUSE, one of the GRUB menu items was automatically named
> as "Windows 7 на /dev/sda1" ("на" - possible cause of the failure).
> If you need any additional files for diagnosis, please write.
> 
> Software versions:
> yast2-bootloader - 4.0.15-1.1
> yast2 - 4.0.49-1.1
> 
> Error code:
> 
> /usr/lib/YaST2/bin/y2start:58:in `<main>'
> 2018-02-11 21:12:59 <3> compik(23411) [Ruby] yast/wfm.rb:276 Internal error.
> Please report a bug report with logs.
> Run save_y2logs to get complete logs.

Please do so ;-) For details see https://en.opensuse.org/openSUSE:Report_a_YaST_bug#I_reported_a_YaST2_bug.2C_and_now_I_am_asked_to_.22attach_y2logs.22_.28for_package_installation_also_.22libzypp_logging.22.29._What_does_that_mean.2C_and_how_do_I_do_that.3F
Comment 2 Alex Zauzolkov 2018-02-12 09:39:05 UTC
(In reply to Michal Filka from comment #1)
> Please do so ;-)

But "y2log-qIBJRE.tar.xz" was already attached to the first message yesterday.
I executed the command "save_y2logs" and did everything as in the instruction: "create a new bugzilla attachment to the appropriate bug with that /tmp/y2logs.tgz file."

Did I uploaded the wrong file? 

> Log file from save_y2logs (5.33 MB, application/x-xz)
> 2018-02-11 11:40 UTC, Alex Zauzolkov
Comment 3 Lukas Ocilka 2018-02-12 11:44:19 UTC
No, you've done it well, thanks!

Michal most probably overlooked that in the initial message.
Comment 4 Lukas Ocilka 2018-02-12 11:46:26 UTC
Josef, PLS, check CFA in this bug, but do it after Beta7 tasks
Comment 5 Josef Reidinger 2018-02-12 12:52:37 UTC
It is known issue, looks like inconsistency between root locale when generated this file and when reading it.

I will have to play with it a bit and find way how to at least not crash when it happen.

*** This bug has been marked as a duplicate of bug 1074543 ***