Bug 1080454 - Wayland KDE Session can spin the cube, but all desktops are black. AMD A-Series APU.
Wayland KDE Session can spin the cube, but all desktops are black. AMD A-Seri...
Status: RESOLVED DUPLICATE of bug 1080578
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: KDE Workspace (Plasma)
Current
Other Other
: P5 - None : Major (vote)
: ---
Assigned To: E-Mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-11 04:08 UTC by Rick Stockton
Modified: 2018-03-03 17:29 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---
wbauer: needinfo? (rickstockton)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rick Stockton 2018-02-11 04:08:32 UTC
Two problems, which I can separate if you prefer.
#1) Attempting a "Plasma on Wayland" Session creates the following symptoms on login: Black screen (No panels, no decorations except mouse pointer). But The mouse is completely functional: It tracks to the screen edges and invokes "hot corner" and "hot edge" Window Manager activities. "Desktop Cube" can be invoked, and it shows a cube cap (and cube base) for an 8-sided cube of black Desktops. But of course, upon selecting a desktop, you can't invoke an application: There is no menu, no panels, no icons; just black screen with the mouse cursor on top.
The only way out is pressing BOB. (Or the software equivalent: Switch to Ctrl-Alt-Fx terminal and issue "telinit 6" as root.)

#2) It is not obvious how or where the KDE session type (X11 or Wayland) is subsequently controlled. After a nearly total removal and re-installation of qt and KDE, I am able to get a GDM login manager which displays two kinds of Plasma sessions - but they BOTH fall into a Wayland Session as above.

I then tried to configure an auto-login user, but the "choice of desktop" has insufficient granularity. I'll be running XFCE until you =can coach me with instructions for getting back to KDE/Plasma.

I think this is a "major" problem. If "Leap-15 Beta" also falls into this kind of problem for every AMD A-Series computer, you may need to disable the KDE-on-Wayland feature there as well.
Comment 1 Rick Stockton 2018-02-11 04:10:19 UTC
At the time I open the bug Plasma and Kwin are at: 5.12.0-1.1
Comment 2 Rick Stockton 2018-02-11 04:14:32 UTC
Drafting as "high Priority", "Major" - but adjust upon assignment, if you all think it is not so serious.
Comment 3 Eric Sander 2018-02-11 11:17:18 UTC
Same with me. Black Screen, but Skype Preview (with X11 Keychain question) and PulseAudio system tray shows up.
After rm -rf ~/.cache and rm -rf /var/lib/sddm/.cache I had the Session back.
Comment 4 Wolfgang Bauer 2018-02-12 14:33:59 UTC
(In reply to Eric Sander from comment #3)
> Same with me. Black Screen, but Skype Preview (with X11 Keychain question)
> and PulseAudio system tray shows up.
> After rm -rf ~/.cache and rm -rf /var/lib/sddm/.cache I had the Session back.

That would be caused by a (meanwhile fixed) bug in Mesa then.
See bug#1079465 .

@reporter: does it help in your case as well?
What about using a different displaymanager than GDM?
A KDE installation uses SDDM by default.

You should file a separate bug against GNOME for your "usability problems" with GDM anyway.
Comment 5 Rick Stockton 2018-02-14 05:53:54 UTC
"rm -rf ~/.cache", with "rm -rf /var/lib/sddm/.cache"
and with "rm -rf /var/lib/gdm/.cache" has not improved matters for the broken UserID.

Now running with updates through today ("zypper dup"). A new UserID is able to log in (KDE) as an autologin user via SDDM, and my old userID is able to reach XFCE as an autologin user. (I imagine that to be using GTK2, therefore pre-Wayland.)

If I try and logout to a GDM, the screen graphics are present and the mouse moves - but nothing can be clicked with any response any more (It's now actually worse).

I'll see about a New UserID logging out to GDM and being able to lock back in. If that works, then I'll try to log the new UserID into KDE from GDM, and swtich by DM over to SDDM. The system has created an X11 error warning about a failed "Plane Write" operation when freezing in the Login Managers, but I lost track of which log file it has appeared in.
- - - - - 
I'm leaving "needinfo" pointed at me, pending further tests with newly created UserIDs. If they don't fail, then I should probably move my "dead User" data files into a new ID and destroy the dead one, or rebuild the entire box fresh.
Comment 6 Rick Stockton 2018-03-03 17:29:54 UTC
This problem has been fixed by the resolution of bug 1080578, and I'm marking it as a "DUP" of that bugID. (DM's work correctly, and KDE desktops work correctly - including that of my "original, main UserID".) My thanks to everyone involved in pulling the upstream fixes!

*** This bug has been marked as a duplicate of bug 1080578 ***