Bug 1080429 - kolourpaint missing dependency on kdelibs4support
kolourpaint missing dependency on kdelibs4support
Status: RESOLVED DUPLICATE of bug 1055759
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: KDE Applications
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-Mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-10 08:18 UTC by Stefan Seyfried
Modified: 2018-02-12 14:19 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Seyfried 2018-02-10 08:18:34 UTC
On my XFCE system with basic KDE already installed (I'm a yakuake "heavy user" :), I installed kolourpaint. Great little app, but I was unable to save my edited picture.

Console output:
kf5.kio.core: Refilling KProtocolInfoFactory cache in the hope to find "mtp"
kf5.kservice.services: KServiceTypeTrader: serviceType "ThumbCreator" not found
kf5.kservice.services: KServiceTypeTrader: serviceType "ThumbCreator" not found
No file found for ".xml" , even though update-mime-info said it would exist.
Either it was just removed, or the directory doesn't have executable permission... ("/home/seife/.local/share/mime", "/usr/share/mime")
kf5.kservice.services: KServiceTypeTrader: serviceType "ThumbCreator" not found
kf5.kservice.services: KServiceTypeTrader: serviceType "ThumbCreator" not found
kf5.kservice.services: KServiceTypeTrader: serviceType "ThumbCreator" not found
kf5.kservice.services: KServiceTypeTrader: serviceType "ThumbCreator" not found
kf5.kservice.services: KServiceTypeTrader: serviceType "QImageIOPlugins" not found

googled, found the hint for "kbuildsycoca5 --noincremental". Helped a bit, but saving still did not work:
kf5.kservice.services: KServiceTypeTrader: serviceType "QImageIOPlugins" not found

Googled again, found this in the changelog of gwenview on packagehub:
* Thu Sep 29 2016 alarrosa@suse.com
  - Added a require for kdelibs4support since that package provides
    qimageioplugins services for jpeg, png, gif and other image formats
    and gwenview5 can't be used without it (boo#1001276).

So maybe the same solution would be apropriate for kolourpaint.
Comment 1 Christoph Feck 2018-02-10 12:30:40 UTC
Maybe /usr/share/kservicetypes5/qimageio_plugin.desktop could be in KService framework; a separate package looks excessive.
Comment 2 Wolfgang Bauer 2018-02-12 14:19:47 UTC
(In reply to Stefan Seyfried from comment #0)
> On my XFCE system with basic KDE already installed (I'm a yakuake "heavy
> user" :), I installed kolourpaint. Great little app, but I was unable to
> save my edited picture.

Already reported, but the reporter didn't respond since months...

> Googled again, found this in the changelog of gwenview on packagehub:
> * Thu Sep 29 2016 alarrosa@suse.com
>   - Added a require for kdelibs4support since that package provides
>     qimageioplugins services for jpeg, png, gif and other image formats
>     and gwenview5 can't be used without it (boo#1001276).
> 
> So maybe the same solution would be apropriate for kolourpaint.

That fix got lost a few months later again though, becaue it never was submitted to the unstable packages.

IMHO, the better solution would be to make libKF5KDELibs4Support5 require kdelibs4support instead of several single applications.

(In reply to Christoph Feck from comment #1)
> Maybe /usr/share/kservicetypes5/qimageio_plugin.desktop could be in KService
> framework; a separate package looks excessive.

That would need to be done upstream though.
But I think only libKF5KDELibs4Support5 uses/needs this file.

*** This bug has been marked as a duplicate of bug 1055759 ***