Bug 1080341 - tilda is crashing in wayland session
tilda is crashing in wayland session
Status: RESOLVED UPSTREAM
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Malcolm Lewis
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-09 16:39 UTC by Victor Zhestkov
Modified: 2018-04-07 15:49 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Victor Zhestkov 2018-02-09 16:39:06 UTC
tilda is going to segmentation fault in running under wayland session
Comment 1 Vasilis Liaskovitis 2018-02-16 15:29:00 UTC
Confirmed.

These tickets:
https://github.com/lanoxx/tilda/issues/314
https://github.com/lanoxx/tilda/issues/150

suggest using: 

GDK_BACKEND=x11 tilda

That worked for me. Can you try it?

According to the above tickets, tilda hotkeys may not work though.
Comment 2 Victor Zhestkov 2018-02-16 19:37:06 UTC
Yes, this method works.
But anyway need to be fixed :-)
Comment 3 Marcus Meissner 2018-02-20 16:05:48 UTC
Malcolm touched it last. 

I am the project bugowner, not the package bugowner ;)
Comment 4 Malcolm Lewis 2018-02-21 17:38:47 UTC
Hi
Well there seem to be a couple of issues, one the developer is not up to speed on wayland and indicates in Issue #314 that it's (tilda) Xorg only.

Second is the hotkeys. At preset I run Xorg on Gnome in TW, but did test the latest release (1.4.1) in SLED 15 Beta7 since it's running wayland, no hotkey working is a pain.

Depending on your desktop environment, not sure if there is a real fix, yes it starts if I patched the desktop file (or created a wrapper), but until upstream fixes reluctant to do anything else....
Comment 5 Malcolm Lewis 2018-04-07 15:49:47 UTC
Waiting for upstream so will close.