Bug 1080313 - some keys stops working in Midnight Commander in gnome-terminal with latest updates
some keys stops working in Midnight Commander in gnome-terminal with latest u...
Status: RESOLVED DUPLICATE of bug 1079543
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
x86-64 openSUSE Factory
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-09 14:55 UTC by Victor Zhestkov
Modified: 2018-02-09 15:20 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Victor Zhestkov 2018-02-09 14:55:11 UTC
With latest updates it seems that default TERM environment variable has changed to xterm-256color value. I think it's the reason why some keys stop working:
arrow keys (up, down)
some function keys (F10 works only on second time of pressing)
and probably more


I've changed TERM value to xterm:
export TERM=xterm
and now it works fine until next start of the gnome-terminal
COLORTERM=truecolor also affect the colors in MC in strange way. without COLORTERM environment variable MC looks better.
Comment 1 Egmont Koblinger 2018-02-09 15:20:35 UTC
This is caused by an incompatibility between terminfo and slang, see the duplicate report.

This is not a bug in gnome-terminal, which has, by the way, defaulted to TERM=xterm-256color for about 3 years now.

*** This bug has been marked as a duplicate of bug 1079543 ***