Bug 1080293 - screen-256color stopped working with update to terminfo 6.1
screen-256color stopped working with update to terminfo 6.1
Status: RESOLVED DUPLICATE of bug 1079543
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Basesystem
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Dr. Werner Fink
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-09 13:13 UTC by Andreas Schneider
Modified: 2018-02-10 08:15 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Schneider 2018-02-09 13:13:46 UTC
I'm using tmux and and terminfo didn't want to support tmux and told people to use screen-256color. That worked fine till the update to terminfo-6.1-1.1.x86_64

asn:~ # mc
Unknown terminal: screen-256color
Check the TERM environment variable.
Also make sure that the terminal is defined in the terminfo database.
Alternatively, set the TERMCAP environment variable to the desired
termcap entry.

rpm -ql terminfo | grep screen-256color
/usr/share/terminfo/s/screen-256color-bce
/usr/share/terminfo/s/screen-256color-bce-s
/usr/share/terminfo/s/screen-256color-s
Comment 1 Andreas Schneider 2018-02-09 13:29:01 UTC
TERM=screen-256color-s mc
Unknown terminal: screen-256color-s
Check the TERM environment variable.
Also make sure that the terminal is defined in the terminfo database.
Alternatively, set the TERMCAP environment variable to the desired
termcap entry.
Comment 2 Dr. Werner Fink 2018-02-10 08:15:37 UTC
Not a bug of ncurses but of slang as this library does not handle new 32bit format of ncurses 6.1

Run
 
  file /usr/share/terminfo/s/screen-256color*

to identifiy the new format

*** This bug has been marked as a duplicate of bug 1079543 ***